Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: Era II
Thread: Era II This Popular Thread is 139 pages long: 1 20 40 60 80 100 120 ... 130 131 132 133 134 ... 139 · «PREV / NEXT»
Pmdavidson
Pmdavidson

Tavern Dweller
posted December 02, 2016 07:58 PM

Galaad said:
Sounds like a bad install, reinstall doing these steps:

1. Install CLEAN copy of h3 SoD/Complete
2. Install Era II


I've done that multiple times. I've used Crossover, the Porting Kit and Wine in various other forms. All with the same result.


Salamandre said:
Pmdavidson]the "wogify" options won't appear both before starting a map and during the actual gameplay./quote said:


What map you tried? Some custom maps block entirely wog settings.


Every map has  had the same issue. I can't even open my WOG options before the game starts. It's clear that the game is recognizing my clicking on the button because the cursor changes and I'm unable to click on the "main" screen. I have to hit "esc" or "enter" to blindly get out of the WOG options window that is failing to materialize on screen. Then if I am able to blindly get the game to start, I get a "use default or custom teams" prompt  (custom won't work since I can't see the window that should pop up) and then once the game starts any WOG window that should pop-up simply doesn't. It's like a ghost that's present and has effect but won't reveal itself. So as of now, I'm resolved to just playing my clean H3 edition until I can figure out what's happening.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Galaad
Galaad


Honorable
Undefeatable Hero
Forge activist
posted December 02, 2016 08:15 PM
Edited by Galaad at 20:32, 02 Dec 2016.

I never used Crossover but I do use wine to run my Era II and I have no problems, don't you have some log or something that could help pinpoint where your issue is coming from?

Also does this happen even before you've installed any mods?

EDIT: How did you install Era through wine exactly?
____________
"Corribus is a teddy bear" - Blizzardboy

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Pmdavidson
Pmdavidson

Tavern Dweller
posted December 03, 2016 09:34 AM

Galaad said:
I never used Crossover but I do use wine to run my Era II and I have no problems, don't you have some log or something that could help pinpoint where your issue is coming from?

Also does this happen even before you've installed any mods?

EDIT: How did you install Era through wine exactly?


That's the thing, without the mods it works perfectly.

I created a blank wrapper and then using wineskin within the wrapper, I installed the exe for H3 complete GOG ed, the exe patch for it, H3HD exe, and then era 2.46 exe. After installing all of them to a H3 folder on my C drive, I ran the program with HDlauncher and it boots and looks like it would play fine but then none of the WOG options screens appear.

Here's my log info:

WineskinX11: main(): argc=12
Waiting for startup parameters via Mach IPC.
WineskinX11: do_start_x11_server(): argc=12
Attempting to use pixel depth of 24
[3284605.960] WineskinX11 starting:
[3284605.960] X.Org X Server 1.13.0
[3284605.960] Build Date: 20120921
[3284605.960] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.
[3284605.964] Initializing built-in extension Generic Event Extension
[3284605.964] Initializing built-in extension SHAPE
[3284605.964] Initializing built-in extension MIT-SHM
[3284605.964] Initializing built-in extension XInputExtension
[3284605.964] Initializing built-in extension XTEST
[3284605.964] Initializing built-in extension BIG-REQUESTS
[3284605.964] Initializing built-in extension SYNC
[3284605.964] Initializing built-in extension XKEYBOARD
[3284605.964] Initializing built-in extension XC-MISC
[3284605.964] Initializing built-in extension XINERAMA
[3284605.964] Initializing built-in extension PseudoramiX
[3284605.964] Initializing built-in extension XFIXES
[3284605.964] Initializing built-in extension RENDER
[3284605.964] Initializing built-in extension RANDR
[3284605.964] Initializing built-in extension DAMAGE
[3284605.964] Initializing built-in extension MIT-SCREEN-SAVER
[3284605.964] Initializing built-in extension DOUBLE-BUFFER
[3284605.964] Initializing built-in extension RECORD
[3284605.964] Initializing built-in extension X-Resource
[3284605.964] Initializing built-in extension XVideo
[3284605.964] Initializing built-in extension XVideo-MotionCompensation
[3284605.964] Initializing built-in extension GLX
[3284605.965] x: 0, y: 0, w: 1280, h: 777
[3284606.018] (II) GLX: Initialized Core OpenGL GL provider for screen 0
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/75dpi, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/100dpi, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/cyrillic, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/misc, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/OTF, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/Speedo, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/TTF, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/Type1, removing from list!
[3284606.019] [dix] Could not init font path element /opt/X11/share/fonts/util, removing from list!
[3284606.222] noPseudoramiXExtension=0, pseudoramiXNumScreens=1
Engine Used: WS9Wine1.9.24
Hardware:

   Hardware Overview:

     Model Name: MacBook Pro
     Model Identifier: MacBookPro7,1
     Processor Name: Intel Core 2 Duo
     Processor Speed: 2.4 GHz
     Number of Processors: 1
     Total Number of Cores: 2
     L2 Cache: 3 MB
     Memory: 4 GB
     Bus Speed: 1.07 GHz
     Boot ROM Version: MBP71.0039.B0E
     SMC Version (system): 1.62f7
     Sudden Motion Sensor:
         State: Enabled

Graphics/Displays:

   NVIDIA GeForce 320M:

     Chipset Model: NVIDIA GeForce 320M
     Type: GPU
     Bus: PCI
     VRAM (Total): 256 MB
     Vendor: NVIDIA (0x10de)
     Device ID: 0x08a0
     Revision ID: 0x00a2
     ROM Revision: 3533
     Displays:
       Color LCD:
         Display Type: LCD
         Resolution: 1280 x 800
         Pixel Depth: 32-Bit Color (ARGB8888)
         Main Display: Yes
         Mirror: Off
         Online: Yes
         Built-In: Yes

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Galaad
Galaad


Honorable
Undefeatable Hero
Forge activist
posted December 03, 2016 10:38 AM

Pmdavidson said:

[3284605.960] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.


You're on a mac right? You need to install XQuartz.
https://support.apple.com/en-us/HT201341
____________
"Corribus is a teddy bear" - Blizzardboy

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Pmdavidson
Pmdavidson

Tavern Dweller
posted December 03, 2016 06:42 PM

Galaad said:
Pmdavidson said:

[3284605.960] _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not be created.


You're on a mac right? You need to install XQuartz.
https://support.apple.com/en-us/HT201341


Okay so I installed Xquartz but no luck.

fixme:exec:SHELL_execute flags ignored: 0x00000100
fixme:ver:GetCurrentPackageId (0x33f010 0x0): stub
fixme:ver:GetCurrentPackageId (0x2b3f1e0 0x0): stub
err:winediag:query_gpu_description Invalid GPU override 10de:08a0 specified, ignoring.
fixme:win:EnumDisplayDevicesW ((null),0,0x2b3f33c,0x00000000), stub!
fixme:x11drv:X11DRV_desktop_SetCurrentMode Cannot change screen BPP from 32 to 16
errle:CoGetClassObject class {5959df60-2911-11d1-b049-0020af30269a} not registered
errle:CoGetClassObject no class object {5959df60-2911-11d1-b049-0020af30269a} could be created for context 0x1
fixmeplay:IDirectPlayLobby3AImpl_RegisterApplication :stub
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
fixme:keyboard:X11DRV_ActivateKeyboardLayout 0x4090409, 0000: semi-stub!
err3d:resource_unload Resource 0x1cde78 is being unloaded while mapped.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Galaad
Galaad


Honorable
Undefeatable Hero
Forge activist
posted December 03, 2016 08:06 PM
Edited by Galaad at 20:14, 03 Dec 2016.

Ugh.

Sadly I have no mac at disposal to try it myself right now. Maybe there is another thing you can try, is to use PlayonMac.

Delete h3 and reinstall it yet again, this time doing these steps:
From PlayonMac GUI choose "install a non-listed program". Choose a version of wine (latest should be fine), select 32 bits install and also install following libraries: gdiplus and directplay. After it installed, don't launch the game and hit exit, create a shortcut for the virtual drive. If you got homm3 from gog and you need to patch, install the patch by going to misc tab and select "run .exe in this virtual drive" and run the patch.
Then install Era the same way you installed the patch, and hit "create another shortcut" from one of the menus of the updated virtual drive, and create your h3era shortcut. Don't install the HD mod yet, try to see if this works then report again.

Fingers crossed.

Edit: Oh yeah, before you run the game run wineconfig and select Windows 7 or XP and under Graphics tab "capture mouse in fullscreen".
____________
"Corribus is a teddy bear" - Blizzardboy

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Pmdavidson
Pmdavidson

Tavern Dweller
posted December 04, 2016 10:48 AM

Galaad said:
Ugh.

Sadly I have no mac at disposal to try it myself right now. Maybe there is another thing you can try, is to use PlayonMac.

Delete h3 and reinstall it yet again, this time doing these steps:
From PlayonMac GUI choose "install a non-listed program". Choose a version of wine (latest should be fine), select 32 bits install and also install following libraries: gdiplus and directplay. After it installed, don't launch the game and hit exit, create a shortcut for the virtual drive. If you got homm3 from gog and you need to patch, install the patch by going to misc tab and select "run .exe in this virtual drive" and run the patch.
Then install Era the same way you installed the patch, and hit "create another shortcut" from one of the menus of the updated virtual drive, and create your h3era shortcut. Don't install the HD mod yet, try to see if this works then report again.

Fingers crossed.

Edit: Oh yeah, before you run the game run wineconfig and select Windows 7 or XP and under Graphics tab "capture mouse in fullscreen".


YES!! I had to play with some of the settings a bit after the install because I had screen flickering but it is now 100% working. Thank you very much for the step by step instructions and for all of the help. You rock.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Galaad
Galaad


Honorable
Undefeatable Hero
Forge activist
posted December 04, 2016 11:34 AM

Yay, good job mate!
Hope you enjoy Era, there's a lot to explore.
____________
"Corribus is a teddy bear" - Blizzardboy

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Pmdavidson
Pmdavidson

Tavern Dweller
posted December 06, 2016 08:11 AM

Galaad said:
Yay, good job mate!
Hope you enjoy Era, there's a lot to explore.


I've been enjoying Era but now I'm having an issue where in battle the ground animation is completely blank and the unit animations are hanging in their places as if to make a duplicate of the original, even after they're dead. Any ideas?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted December 06, 2016 08:39 AM

Disable "new battlefields" in wog options, then install Morn Battlefields mod. There is some graphic incompatibility with win7 and +.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Pmdavidson
Pmdavidson

Tavern Dweller
posted December 07, 2016 06:43 AM

Salamandre said:
Disable "new battlefields" in wog options, then install Morn Battlefields mod. There is some graphic incompatibility with win7 and +.


Perfect! Thanks!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 05, 2017 07:42 PM

Hi! Can someone help me why when i launch the game this error appears>
Gameext.pas on line 122 Error at address $55F0ADC ?
I reinstall 3 times the whole game but nothing.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted January 06, 2017 08:35 PM

Make sure that the original game is not in Program files folder. Then download era2 from wakeofgods.org/mods and install it. Unless you have a weird OS configuration, it should work. Btw, if you look closely to the mods in that list, you will even find the full heroes game, be my guest.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 07, 2017 06:18 PM

Salamandre said:
Make sure that the original game is not in Program files folder. Then download era2 from wakeofgods.org/mods and install it. Unless you have a weird OS configuration, it should work. Btw, if you look closely to the mods in that list, you will even find the full heroes game, be my guest.


Thank you very much for your response. But it was from Knightmare mods. It was from
Knightmare War Machines.era (Knightmare Warchest Mod) and
Skirmish.era (amethyst upgrades mod).

After i delete those files the game works fine.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted January 07, 2017 07:59 PM

Well, you didn't precise, this is Era II thread, I wasted my time responding since your game works as default but stops working when using that mod. Next time please specify or post your error message in Knightmare mod thread.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
artu
artu


Promising
Undefeatable Hero
My BS sensor is tingling again
posted January 12, 2017 07:48 AM
Edited by artu at 07:49, 12 Jan 2017.

Btw, a few days ago, I saw Grayface posting the upgraded versions of his modding tools, the thread is already buried away. The tools are in the Era package. It might be a good idea to repack Era 2.46 with latest tools and update the main download link.
____________
I hope I am mistaking - frostysh

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted January 12, 2017 09:23 AM

There are many things on the update list, mod manager, scripts and now tools. Personally I don't know how to create a new package, there are tons of dependencies, then Bersy just got happily married and I suppose Era is his last worry.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fred79
fred79


Promising
Undefeatable Hero
Crotch Connoisseur
posted January 12, 2017 10:26 AM

Salamandre said:
Bersy just got happily married and I suppose Era is his last worry.


women always come between us guys and our games.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
szaman
szaman


Adventuring Hero
posted January 25, 2017 12:12 AM

Does anyone know how to open a file with "era extension?". Found this in random skins mod and i what to know how does it work. I think its a plugin... but its not a dll.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
igrik
igrik


Adventuring Hero
posted January 25, 2017 11:42 AM

It's rename plugin dll->era.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This Popular Thread is 139 pages long: 1 20 40 60 80 100 120 ... 130 131 132 133 134 ... 139 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.4747 seconds