Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 5 - Temple of Ashan > Thread: Screen flicker, crashes, stutter, etc
Thread: Screen flicker, crashes, stutter, etc
Strogglet
Strogglet

Tavern Dweller
posted June 03, 2012 11:34 PM
Edited by Strogglet at 15:46, 04 Jun 2012.

Screen flicker, crashes, stutter, etc

I don't know where exactly I should put this, but I think it's here, please don't maul me for putting a thread on the wrong section.

Anyway, I'd like to tell about my problem here which I hope someone can fix it, it's horribly annoying...

I have Heroes 5, all the expansions, all are updated to the latest and such. Now, the problem I am having is, that around 30 minutes or so, the game starts to flicker like crazy.

I do not get the problem at all, when I alt+tab I see the "Driver stopped responding and successfully reset" or something like that, the typical annoying error of Nvidia's. I have done all the things to disable that, it was;

1. Disable Nvidia Powermizer's completely.
2. Go to Nvidia's Control Panel and set power management to "maximum"

But I still get those flickers and crashes, I do not understand why. I tried many other ways to fix this, using Nvidia's control panel especially. Nothing worked...Anti-aliasing, anisotropic filtering, VSync, threaded optimization...Nothing at all worked.

I thought it might be overheating or something else, so I enabled Nvidia's Powermizer for it to stop overheating. I never over-clocked any of my system hardwares by the way. And yet it still flickers annoyingly!

I can probably make a video of what's going on if really needed.

A small detail too which I got it fixed, it seems that either "Threaded Optimization" or "Nvidia's Powermizer" makes Heroes 5 go on a low FPS spike (Going low than 10 fps), most obvious when you're in combat and you see some effects. This is fixed though, just saying in case needed, and in case you'll tell me to enable one of the two, which I doubt will work.

Yet, there are some more details you should know;

1. I am poor so I can't afford any hardware.
2. I feel Heroes 5 worked perfectly before and now it has flickers.
3. I have a feeling this problem is because of registry, broken config or something, but not so sure and didn't see anything wrong with them.

Can anyone help me about this, please?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
SKPRIMUS
SKPRIMUS


Promising
Supreme Hero
The One and the Prime
posted June 04, 2012 05:15 AM

I doubt this will help you much, but I'll say it anyway.

The fact that it works & then later fails due to driver stopped responding seems to point to those 2 things you mentioned

1. Overheating:  biggest issue for me as H5 is the worst graphics card heater upperer in all my games {it's a freakin' TBS!}.  Had one laptop graphics card die to this & another where it just freezes - cannot play H5 in summer on that.  Can't do much except keep it cool.

2. Some strange interplay between graphics card, driver, connection whatever.  Even this may have been result from overheating after long period of play.  Can't do much except get another - this may lead to same problem eventually though.

I have similar probs in H6 but not as much overheating.
____________
Hope defeats despair - "a blatant clue"
too many idiots in VW
"to lose is to win, and he who wins shall lose"
bashing orcus

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Elvin
Elvin


Admirable
Omnipresent Hero
Tastes like chicken
posted June 04, 2012 09:30 AM

Have you updated the graphic drivers? One or two people had the same issue sometime back, will look it up. I think it was either in the technical issues or questions FAQ sticky.
____________
Being human is a roller coaster ride of emotions during rainstorms and sunshine, sprinkled with moments when you can almost reach the stars.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Strogglet
Strogglet

Tavern Dweller
posted June 04, 2012 03:45 PM

Sorry, I forgot an important thing, my system specs;

Windows 7 64-bit
Nvidia GTX 285
Intel Q8400 2.66GHz Quad CPU
4gb of RAM

Quote:
I doubt this will help you much, but I'll say it anyway.

The fact that it works & then later fails due to driver stopped responding seems to point to those 2 things you mentioned

1. Overheating:  biggest issue for me as H5 is the worst graphics card heater upperer in all my games {it's a freakin' TBS!}.  Had one laptop graphics card die to this & another where it just freezes - cannot play H5 in summer on that.  Can't do much except keep it cool.

2. Some strange interplay between graphics card, driver, connection whatever.  Even this may have been result from overheating after long period of play.  Can't do much except get another - this may lead to same problem eventually though.

I have similar probs in H6 but not as much overheating.


Any tries can help me.

I think I have seen a thread talking about this, it mentions over-clocking, and OC most the times also means overheating, but I don't think my Card overheats. The thing is I didn't use GPUZ to see it's heated, I'll do it now anyway.

Another thing, my cooling system is not that bad, it's ironic how powermizer, that Nvidia tool that lowers the clocking when it's needed so it won't overheat, starts making my whole games very unstable and act like it's overheating worse than without using Powermizer.

Not sure about the second one.

Quote:
Have you updated the graphic drivers? One or two people had the same issue sometime back, will look it up. I think it was either in the technical issues or questions FAQ sticky.


Of course, I'm not the typical help asker to be honest, when I ask help it means that I have no ability to do it. I have already updated my graphics card and no difference to them.

I don't even know if I remember well but, before I updated my Nvidia, it seems that the game was fine, but I'm not that sure.

Don't know about anyone else having my problem.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Strogglet
Strogglet

Tavern Dweller
posted June 05, 2012 03:13 PM

Not being extremely impatient, but can anyone help me about this please?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
LucPatenaude
LucPatenaude


Famous Hero
Owning all 6 Heroes games
posted June 05, 2012 04:19 PM

Info. that is critical to know is:

Which version of MMH5 do you try to use?

Do you have the Stand-Alone version of MMH5:Tribes of the East v.3.0 + patch to v.3.1?

I personally believe that only version 3.1 should be thoroughly playable on Win. 7 + Service Pack 1 applied onto it all.

Did you set your monitor and video-graphics chipset's resolution to its highly recommended in performance and quality into the game's Options Menu? Example: Mine is a 24 inches Widescreen LCD monitor that has its best resolution set to 1280 x 768.

Make sure to have downloaded and installed the latest in DirectX graphics decoding files. 9.0c with the newest d3d9.dll from June 2010 and all the others that comes with this, really large filing package.
Winter of 2012 of Device Drivers should be in current use.

From here, the game should load and play as long as you need to finish at least one map. Good Luck!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Strogglet
Strogglet

Tavern Dweller
posted June 07, 2012 06:20 PM
Edited by Strogglet at 18:21, 07 Jun 2012.

Quote:
Which version of MMH5 do you try to use?

Do you have the Stand-Alone version of MMH5:Tribes of the East v.3.0 + patch to v.3.1?

Yes.

Did you set your monitor and video-graphics chipset's resolution to its highly recommended in performance and quality into the game's Options Menu? Example: Mine is a 24 inches Widescreen LCD monitor that has its best resolution set to 1280 x 768.

It's at 1024x786, the recommended, fine enough.

Make sure to have downloaded and installed the latest in DirectX graphics decoding files. 9.0c with the newest d3d9.dll from June 2010 and all the others that comes with this, really large filing package.
Winter of 2012 of Device Drivers should be in current use.

I'm very sure I have it, even used the DirectX on Heroes' installation wizard


Answers in red.

My problem seems not to be fixed yet...I'm sad

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread »
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0304 seconds