Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: The Difference between 3.58f, 3.59, ERA 2.3 and all the else
Thread: The Difference between 3.58f, 3.59, ERA 2.3 and all the else This thread is 2 pages long: 1 2 · NEXT»
UM21
UM21


Adventuring Hero
Hard Defender
posted July 08, 2012 01:09 AM

The Difference between 3.58f, 3.59, ERA 2.3 and all the else

I got many times confused...


Can I get an answer, what is the most newest version of WoG? or is it WoG anymore?

Just a clean basics, but newest one...

Sorry, just got confused... Because it seems any version is the newest version... Could not found it anywhere else either, what it could be.

Thanks... im going sleep, watching answers tomorrow

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Spatiphillum
Spatiphillum


Hired Hero
Phytohobbit
posted July 08, 2012 09:32 AM

3.58f is the latest official WoG at the present time.
3.59 is already dead (for 2 years, AFAIK).
ERA is the rebirth of many features planned in 3.59 and loads of new ideas created by enthusiasts.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Warmonger
Warmonger


Promising
Legendary Hero
fallen artist
posted July 08, 2012 10:32 AM

Quote:
3.58f is the latest official WoG at the present time.

WoG project was already closed at the beginning of this year. There will be no more versions of it.
____________
The future of Heroes 3 is here!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
JimV
JimV


Responsible
Supreme Hero
posted July 08, 2012 02:20 PM

Some people will disagree with this, but I recommend having a WoG 3.58f Heroes folder and an Era 2.3 (or later, when available) Heroes folder.  This will allow you to replay classic WoG 3.58f maps as well as new maps which continue to be written for WoG 3.58f, and new mods created under Era 2.  (Hard drive space is cheap and plentiful these days, I think.)

My understanding is that although WoG 3.59 was never officially finished and released, a couple versions of it exist, and that Bersy chose the most stabile version upon which to base Era.  WoG 3.59 contains several valuable new ERM commands, so a map or mod written for WoG 3.59 will probably not be playable under WoG 3.58f.  Also, some memory addresses have changed between the two, so a WoG 3.58f map might not be playable under WoG 3.59 (but this direction is much more likely to work).

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
UM21
UM21


Adventuring Hero
Hard Defender
posted July 16, 2012 08:48 PM

Oh that's pity that they actually cancelled to do it... However I have always said what human have created, human can modified it

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
egamad
egamad

Tavern Dweller
posted July 17, 2012 03:09 PM

I was also wondering about possible future of WoG, thanks for clearing that up for me.

So basically what you're saying is, that ERA (are we talking about ERA II?) is the new WoG, so to speak? If so, I have a few follow up questions:

- Is ERA still being worked on or is it a final release?
- Are there any existing or WIP mods for ERA?

Thanks for your help.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Bersy
Bersy


Responsible
Supreme Hero
posted July 17, 2012 03:58 PM

It's being worked on from time to time.
The list of mod is not so hard to find: link

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
egamad
egamad

Tavern Dweller
posted July 17, 2012 04:04 PM

I don't know why, but I can't seem to get my way around this forum.. anyway, thanks for taking your time and replying. I've already found a mod or two that will steal my summer away.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Bersy
Bersy


Responsible
Supreme Hero
posted July 17, 2012 04:40 PM

Then try the following link

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RataXes
RataXes

Tavern Dweller
posted August 09, 2012 05:59 PM

Quote:
Some people will disagree with this, but I recommend having a WoG 3.58f Heroes folder and an Era 2.3 (or later, when available) Heroes folder.  This will allow you to replay classic WoG 3.58f maps as well as new maps which continue to be written for WoG 3.58f, and new mods created under Era 2.  (Hard drive space is cheap and plentiful these days, I think.)

Hi! I have Era II installed. I've been downloading Wog-maps from Wake of Gods -yahoo group but every stinking map gives some kind of erm error after launch.

They would actually work if I'd have 3.58f heroes folder?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
JimV
JimV


Responsible
Supreme Hero
posted August 09, 2012 06:22 PM
Edited by JimV at 18:47, 09 Aug 2012.

Whether a WoG 3.58f map will work under Era depends on the map.  Most of the WoG maps on Yahoo Groups (ByteBandits Maps) are old classics which do not use UN:C memory addresses and do not require WoG updates (to be installed via H3wUpd.exe).  They should work under Era.

Oh wait, Era does a syntax check of ERM scripts and objects to things like triple exclamation points - maybe that is what you are referring to (but my mind-reading skills are very weak).  In this case the map will work, but will show some error messages at the start.  Triple exclamation points may be removed from internal scripts as follows:

1) Open the map in the (WoG) Map Editor.

2) Under Files/Export, export the map's text to a text file.

3) Open the text file in a text editor and do an Edit/Replace, replacing !!! with !!.  Resave the file without doing any other changes, or else you might screw up the format.

4) Use Files/Import in the Map Editor to load the modified text.

5) Resave the map with the changes.

Maybe there is a way to disable the syntax check in Era, but I haven't seen it in the Era Manual.

If that is not your problem, you will need to provide more information, such as the name of a map and what the error messages say.

And yes, if that is your problem, running under WoG 3.58f instead of Era will also fix it.

Update: the extra exclamation points occur in comments in the original WoG scripts, e.g., "Warning!!!".  The Era syntax check might object to  even double exclamation points there, so maybe it would be better to replace !!! with ! (but then !!!! would become !!).  If you know what you are doing you can decide which places to edit (based on the error messages) and how, but if not running under WoG 3.58f might be easier.

All the maps should work under WoG 3.58f - it is a WoG archive (not an Era archive).

Further update:  I mentioned that some maps at the archive require WoG updates (installing .wog files).  These should be converted to Era mods (to run them under Era) - see the Era Mod-Makers Manual.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RataXes
RataXes

Tavern Dweller
posted August 10, 2012 09:46 AM

With one reading I can say this much: Unlike Sledgehammer, I don't know what I'm doing. A lot to digest!

I replaced "!!!" with "!!", but it didn't help. I guess that's because what you said, !!! needs to be !.

Anyway, what I think I understood is, that easiest way to play those maps is having 3.58f folder, but where can I have that?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted August 10, 2012 09:50 AM

Can you upload one of those maps?
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RataXes
RataXes

Tavern Dweller
posted August 10, 2012 09:56 AM

Yes sir!

http://www.sendspace.com/file/3045gn

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted August 10, 2012 10:12 AM
Edited by Salamandre at 10:13, 10 Aug 2012.

thanks, there are two issues in this map:

1) multiple exclamation signs once, you can ignore this, is not error, just Era showing them
2) an error in script syntax, which both wog and era will show. The mapmaker forgot to close properly a dialog. I don't think it matters, further scripts should work.

In general, if you get a pop up which starts with !!!, just ignore, isn't error.
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RataXes
RataXes

Tavern Dweller
posted August 10, 2012 10:40 AM
Edited by RataXes at 10:55, 10 Aug 2012.

I (or we, with friend) tried to play for a week, but we (both) get that error at every turn. Slightly annoying. :/ Then there's also this: there's no wog features working at all. Buy all -button, mithrill upgrades, custom alliances etc. Every wog feature gone so.. :/ ignoring won't help much.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted August 10, 2012 12:18 PM
Edited by Salamandre at 12:32, 10 Aug 2012.

Of course there are not wog features, map is scripted to not wogify, it has custom scripts. I ran 2 weeks the game, I did not get any error within Era. Can you post a screen of that error?
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RataXes
RataXes

Tavern Dweller
posted August 10, 2012 02:07 PM

http://postimage.org/image/nq7626uix/

Any way to preserve those custom scripts in the map (since they probably are meant to be there hoh) and still get features like custom allies&buy all -button?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted August 10, 2012 05:51 PM

This error you show is the multiple !!! one, which pops up when map loads. Which is not an error, just a syntax warning. What would help to understand your problem is during game error.

Custom alliances: in editor, check/uncheck players teams

Buy all: supposing you don't know how to open an erm file, just download alexander map from my sig, open map, tools/map specification/events, scroll down until you see "buy all creatures", copy and paste the entire script into an internal event in your map. Should look exactly as in my map, day 670, a description, etc.
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
JimV
JimV


Responsible
Supreme Hero
posted August 10, 2012 05:53 PM
Edited by JimV at 17:55, 10 Aug 2012.

Quote:
Anyway, what I think I understood is, that easiest way to play those maps is having 3.58f folder, but where can I have that?


I think you can get the WoG download at the Yahoo Groups WoG archive, and at Celestial Heavens and maps4heroes, and probably a dozen other places.  Try googling Heroes 3.5 WoG download, or something like that.  You have to install it as an addon to Heroes 3 Complete or Heroes 3 Shadow of Death.

As for custom maps, it is the map-maker's decision to include or not include WoG scripts.  Become a map-maker, and you can make or revise maps as you please.  You could start by reading the map-making tutorial "Introduction to WoG Modding and Scripting" at this site, or similar ones at Celestial Heavens or other sites.  Also, the ERM Help file explains how to add WoG scripts to custom maps.

Edit - I did not intend to step on Salamandre's reply.  It was not showing when I wrote this.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 2 pages long: 1 2 · NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0545 seconds