Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: Knightmare Mods
Thread: Knightmare Mods This thread is 29 pages long: 1 2 3 4 5 ... 10 20 ... 25 26 27 28 29 · «PREV / NEXT»
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 07, 2017 07:14 PM
Edited by majaczek at 19:46, 07 Jan 2017.

Khadras said:
I have HoMM3 HD 4.207 RC1 Mod. I have Win10 latest updated. All the game settings was like in the past.

What version of HD mod i must use?

I have your today's version of mods. So they are up-to-date.

What i must do to make them work with those two files?


you need to use the version of HD-mod which uses version 2.6.0.0 of patcher_x86.dll
note that patcher_x86.dll is used by ERA even when not using HD mod.
if you wish I may check which version of HD-mod it is

EDIT: I guess you need version 3.800 of HD mod
EDIT:  3,808 build 9 could work also.
EDIT: I guess any between the two would work

EDIT: try this one version of HD mod
NOTE: remember to remove patcher_x86.dll prior to instalation or it won't work (it won't replace it with older version of library, so you must remove it prior to instalation so it would work fine)

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 07, 2017 07:59 PM

majaczek said:


you need to use the version of HD-mod which uses version 2.6.0.0 of patcher_x86.dll
note that patcher_x86.dll is used by ERA even when not using HD mod.
if you wish I may check which version of HD-mod it is

EDIT: I guess you need version 3.800 of HD mod
EDIT:  3,808 build 9 could work also.
EDIT: I guess any between the two would work

EDIT: try this one version of HD mod
NOTE: remember to remove patcher_x86.dll prior to instalation or it won't work (it won't replace it with older version of library, so you must remove it prior to instalation so it would work fine)


Thanks, but not working. When i enable those two files the game not start.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 07, 2017 08:10 PM
Edited by majaczek at 20:18, 07 Jan 2017.

Khadras said:
majaczek said:


you need to use the version of HD-mod which uses version 2.6.0.0 of patcher_x86.dll
note that patcher_x86.dll is used by ERA even when not using HD mod.
if you wish I may check which version of HD-mod it is

EDIT: I guess you need version 3.800 of HD mod
EDIT:  3,808 build 9 could work also.
EDIT: I guess any between the two would work

EDIT: try this one version of HD mod
NOTE: remember to remove patcher_x86.dll prior to instalation or it won't work (it won't replace it with older version of library, so you must remove it prior to instalation so it would work fine)


Thanks, but not working. When i enable those two files the game not start.


weird.... it works for me
here is my list.txt
Quote:

WoG
Eng
Czcionki
Yona
WoG Revised
Disable Autosave
WoG PLUS
Knightmare Heroes
Knightmare Difficulty
Knightmare Warchest
Amethyst Upgrades
Knightmare Themes



you need to have those options checked:
Knightmare Creatures upgrades
war machines 1
quicksave

then try again...




PS: I remind you that you  need uninstall HD mod, then remove patcher_x86 then reinstall hd mod in version i provided, else it won't work. I checked it in previous year

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 07, 2017 08:17 PM

I can not enter into the game with those files in the mods. So, i must remove them, enter the game and then do what you told me, and then i put them back to their places?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 07, 2017 08:20 PM

Khadras said:
I can not enter into the game with those files in the mods. So, i must remove them, enter the game and then do what you told me, and then i put them back to their places?



ok now I understand your problem. It is problem with patcher_x86 version 2.7 and higher.


you need:
- uninstall HD mod
- remove patcher_x86 from era folder
- install the version of HD mod I provided


then it should work with those two files you have problem with

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 07, 2017 08:23 PM

I did it but the game do not start. I don't know why. Before downloading your last version of the mod all works fine for me.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 07, 2017 08:31 PM
Edited by majaczek at 20:39, 07 Jan 2017.

Khadras said:
I did it but the game do not start. I don't know why. Before downloading your last version of the mod all works fine for me.


hmm weird. It never worked for me with newest HD mod.

try to download my mods again (and don't overwrite but replace whole folder - that is remove knightmare mods, download them again, put them in correct folders - name matters)

don't enable disabled plugins - they are disabled by reasons

also open your list.txt in mods folder, and place the mods in order I provided (it may matter).

don't enable any mods separate from:

wog
wog revised
wog plus
Knightmare Heroes
Knightmare Difficulty
Knightmare Warchest
Amethyst Upgrades

note - the order is as it is in list.txt - in mods manager it is in reversed order

EDIT: if my dropbox works badly you may use those link: (whole project and all it's versions since some day in 2016 year )
https://bitbucket.org/knightmare_kingdoms/knightmare-kingdoms

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 07, 2017 08:39 PM

I did it and not working.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 07, 2017 08:50 PM
Edited by majaczek at 23:54, 07 Jan 2017.

Khadras said:
I did it and not working.

here it works

really please try to reinstall HD-mod (with replacing patcher_x86)

and last thing I can think of: you may have too old version of VC redistrbutable (but if then it should shout it is missing, not just crash the game) ... please try downloading VC redist 2015 with newest version

EDIT: skirmish text input:
https://www.dropbox.com/s/2i6eu3fyoa7vt0u/Skirmish.png?dl=0


EDIT: you have to use OLDER version of patcher_x86 THAN 2.7 - NOT NEWER
newest version of HD MOD won't work (at least for me) version 2.6 is okay
HD mod with patcher_x86 v.2.6.0.0 is 3.808f build 9

EDIT: any popup or it just crash to desktop?

EDIT: proper version of patcher_x86 is 2.6.0.0
https://www.dropbox.com/s/vrv6gjbwufqkqhg/proper%20version%20of%20patcher_x86.png?dl=0

EDIT: any chances that another mod causes your problem?

EDIT: do you have those files in your system? VCRUNTIME140D.dll ucrtbased.dll ???

EDIT: sorry, now I understand, I made it dependent on debug version of VCruntime instead of release ones, and not everybody have it, I'll try to fix it :|

EDIT: changed those two plugins to Release version (was Debug), now it should work on more computers

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 08, 2017 08:33 AM

majaczek said:

here it works

really please try to reinstall HD-mod (with replacing patcher_x86)

and last thing I can think of: you may have too old version of VC redistrbutable (but if then it should shout it is missing, not just crash the game) ... please try downloading VC redist 2015 with newest version


Look at my versions of VC Redist: http://www.filedropper.com/vcredist

I have version 2015.

majaczek said:

EDIT: skirmish text input:
https://www.dropbox.com/s/2i6eu3fyoa7vt0u/Skirmish.png?dl=0



I can not enter into the game, so i can not see that image. When i press the executable it appears:
http://www.filedropper.com/errorlaunch_1

majaczek said:

EDIT: you have to use OLDER version of patcher_x86 THAN 2.7 - NOT NEWER
newest version of HD MOD won't work (at least for me) version 2.6 is okay
HD mod with patcher_x86 v.2.6.0.0 is 3.808f build 9



I have the correct version of patcher_x86.

majaczek said:

EDIT: any popup or it just crash to desktop?



http://www.filedropper.com/errorlaunch_1

majaczek said:

EDIT: any chances that another mod causes your problem?



I have the same mods like 6 month ago. And i disalbe all other mods and i remains just with yours and wog and nothing different.

majaczek said:

EDIT: do you have those files in your system? VCRUNTIME140D.dll ucrtbased.dll ???


No, i don't.

majaczek said:

EDIT: sorry, now I understand, I made it dependent on debug version of VCruntime instead of release ones, and not everybody have it, I'll try to fix it :|

EDIT: changed those two plugins to Release version (was Debug), now it should work on more computers



I download today's version of your mods but nothing different. It just not working.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 08, 2017 12:53 PM
Edited by majaczek at 13:12, 08 Jan 2017.

vcruntime140D.dll was required by debug version of plugin.
vcruntime140.dll is required by release version of plugin.

ucrtbased.dll is needed by debug version of plugin.
api-ms-win-crt-runtime-l1-1-0.dll is needed by release version of plugin.

the dll-s have to be in the system path or may be in game path if you wish.


game needs version 2.6.0.0 of patcher_x86.dll - not newer not older.


I had same problem with newest version of HD mod or when missing library.


please check your libraries. also check if game is running without knightmare mods. if it doesn't run without knightmare mods it means the guilty is patcher_x86.dll else you need to check you redistributable of VC (vcredist140.dll) and check if you have api-ms-win-crt-runtime-l1-1-0.dll

so i fixed problem with first library but perhaps i introduced new problem ... do you have api-ms-win-crt-runtime-l1-1-0.dll ??? do you have VCREDIST140.dll ?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 08, 2017 02:52 PM
Edited by Khadras at 16:13, 08 Jan 2017.

Hi! I will put those dll in game folder. System not allow me to put them in system32 directory. The game run without knightmare mods so it is not from the patcher.
Thanks. If it will not working then I will wait for new version release of your mods.

Now i install all required dlls but the game won't start. So i must delay the game testing. I don't know what can i do.
In my opinion your last version of mods require a lot of things and i hope in final stage not to be so.
Thanks for help!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 08, 2017 04:31 PM
Edited by majaczek at 17:30, 08 Jan 2017.

Hi!

here is api-ms-win-crt-runtime-l1-1-0.dll library https://support.microsoft.com/en-us/kb/2999226

here probably is vcredist140.dll https://www.microsoft.com/en-US/download/details.aspx?id=48145

note: you probably have vcredist140.dll (knowing you have the runtimes) but you probably don't have api-ms-win-crt-runtime-l1-1-0.dll so please download it. Also probably emerald or some another plugin is incompatible with newer version of patcher_x86.dll than 2.6.0.0 (or was it ERA at all?).


EDIT: change from last minute: new versions of plugins with statically linked runtime, please check them

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 08, 2017 04:56 PM

majaczek said:
Hi!

here is api-ms-win-crt-runtime-l1-1-0.dll library https://support.microsoft.com/en-us/kb/2999226

here probably is vcredist140.dll https://www.microsoft.com/en-US/download/details.aspx?id=48145

note: you probably have vcredist140.dll (knowing you have the runtimes) but you probably don't have api-ms-win-crt-runtime-l1-1-0.dll so please download it. Also probably emerald or some another plugin is incompatible with newer version of patcher_x86.dll than 2.6.0.0 (or was it ERA at all?).


I have all of those above. The same message appears. The game did not started. Perhaps it is more difficult to make 2 OS to function one like other than a new version of mod files.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 08, 2017 05:44 PM

in last minutes I published new version of plugins: they have staticaly linked runtime.
that means: they should have guts in, not out.
try to swap them (only plugins changed)

PS: I don't guarantee that it would work with another version of HD mod than I use. I guarantee that it should work, at least on my computer, however if somebody doesn't have something important in their OS it may don't work

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 08, 2017 07:45 PM
Edited by Khadras at 19:47, 08 Jan 2017.

majaczek said:
in last minutes I published new version of plugins: they have staticaly linked runtime.
that means: they should have guts in, not out.
try to swap them (only plugins changed)

PS: I don't guarantee that it would work with another version of HD mod than I use. I guarantee that it should work, at least on my computer, however if somebody doesn't have something important in their OS it may don't work


Now the message not appear but the game not start and is stopped from processes by the system. It is a step, but the game not start also.

When i forced it system says: "can not create process! Error code = 740."

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 08, 2017 09:04 PM

Khadras said:
majaczek said:
in last minutes I published new version of plugins: they have staticaly linked runtime.
that means: they should have guts in, not out.
try to swap them (only plugins changed)

PS: I don't guarantee that it would work with another version of HD mod than I use. I guarantee that it should work, at least on my computer, however if somebody doesn't have something important in their OS it may don't work


Now the message not appear but the game not start and is stopped from processes by the system. It is a step, but the game not start also.

When i forced it system says: "can not create process! Error code = 740."


It's fault of AntiVirus probably. Mark libraries as False Positive (which means "I know that AV recognised this as malware but I am sure it's safe, and it comes from trusted source").
Note: some AVs marks software as bad one just because it have low number of copies in the wild.
PS: you may mark all ERA plugins from me as exception from AV scanning, but maybe wiser is send it to AV company and wait for them checking it is really false positive.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Khadras
Khadras


Known Hero
posted January 09, 2017 10:48 AM

All Heroes 3 directory is marked for exclusion in my AV for a long time ago and for the future. It is not the first time when my AV make me crazy but in this case AV is nothing to do about. I disable it and i put in exception list all files from Heroes 3 directory. For example, at my office i do not have any AV programs and the game not started also. In this case AV is innocent.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 09, 2017 01:21 PM
Edited by majaczek at 16:42, 09 Jan 2017.

Khadras said:
All Heroes 3 directory is marked for exclusion in my AV for a long time ago and for the future. It is not the first time when my AV make me crazy but in this case AV is nothing to do about. I disable it and i put in exception list all files from Heroes 3 directory. For example, at my office i do not have any AV programs and the game not started also. In this case AV is innocent.


okay - it's why i said "probably"
note that emerald needs patcher_x86 to work. on my side it doesn't work with newer version of patcher_x86 than 2.6.0.0 (don't remember which error message) also there are other probable uses of it in ERA game (even when not using HD mod), so do you have proper version of the library? and please remove the copies of system libraries (if any) that you pushed into heroes3era folder (any crt  or vcredist ones) since it may not work well with something.

EDIT: the errorcode you provided means you need  admin rights (weird?). try to  run game as admin, at least for the first time.
EDIT2: it may be that windows marked files as downloaded from internet, so you need rightclick them, click properties and uncheck some box, it may help.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted January 13, 2017 09:50 PM

Changes to war machines script  and war machines plugins - now it uses different variables so it should not spoil variable memory, also almost all checks for artifact numbers are done outside of ERM - they are in plugin and uses Hero pointer -> artifact slot instead of checking in loop ffor checking if each artifact is present - it should work in very short delays of time. perhaps there will be more war machines (in plans: cannon, Poison tent, Inflamation tent)

Khadras please check if new version works for you

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 29 pages long: 1 2 3 4 5 ... 10 20 ... 25 26 27 28 29 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0830 seconds