Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: [HotA] Bugreports. Critical bugs.
Thread: [HotA] Bugreports. Critical bugs. This thread is 13 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 · «PREV / NEXT»
krs
krs


Famous Hero
posted December 22, 2014 04:54 PM

Are the vampires and wights misplaced?



(HotA + HD)

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Sav
Sav


Known Hero
posted December 22, 2014 05:04 PM

No. This is standart position for all 1-hex creatures in creature banks in SoD.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Revdog
Revdog

Tavern Dweller
posted December 23, 2014 09:59 PM
Edited by Revdog at 22:20, 23 Dec 2014.

unhandled exception

I have a full version of HOTA running in (x86) program files on win 7
I have unckecked the update box on start up box but when you go back in its checked again. If I uncheck the box and then click on play game the 3DO screen comes up and then it stalls. if I exit the launcher and click the EXE I get unhandled exception saying the input string was not in the correct format HELP

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.FormatException: Input string was not in a correct format.
  at System.Number.StringToNumber(String str, NumberStyles options, NumberBuffer& number, NumberFormatInfo info, Boolean parseDecimal)
  at System.Number.ParseInt32(String s, NumberStyles style, NumberFormatInfo info)
  at System.Diagnostics.PerformanceCounterLib.GetStringTable(Boolean isHelp)
  at System.Diagnostics.PerformanceCounterLib.get_NameTable()
  at System.Diagnostics.PerformanceCounterLib.get_CategoryTable()
  at System.Diagnostics.PerformanceCounterLib.CounterExists(String category, String counter, Boolean& categoryExists)
  at System.Diagnostics.PerformanceCounterLib.CounterExists(String machine, String category, String counter)
  at System.Diagnostics.PerformanceCounter.Initialize()
  at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, String instanceName, Boolean readOnly)
  at System.Diagnostics.PerformanceCounter..ctor(String categoryName, String counterName, String instanceName)
  at HotA_Launcher.formMain.saveupdBtn_Click(Object sender, EventArgs e)
  at HotA_Launcher.formMain.formMain_Load(Object sender, EventArgs e)
  at System.Windows.Forms.Form.OnLoad(EventArgs e)
  at System.Windows.Forms.Control.CreateControl(Boolean fIgnoreVisible)
  at System.Windows.Forms.Control.CreateControl()
  at System.Windows.Forms.Control.WmShowWindow(Message& m)
  at System.Windows.Forms.Control.WndProc(Message& m)
  at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
  at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
   CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
HotA_launcher
   Assembly Version: 0.0.0.3
   Win32 Version: 0.5.0.0
   CodeBase: file:///C:/Program%20Files%20(x86)/Heroes%203%20HotA/HotA_launcher.exe
----------------------------------------
System.Windows.Forms
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
   CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
   CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
   Assembly Version: 2.0.0.0
   Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
   CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Microsoft.VisualBasic
   Assembly Version: 8.0.0.0
   Win32 Version: 8.0.50727.5483 (Win7SP1GDR.050727-5400)
   CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
   <system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Revdog
Revdog

Tavern Dweller
posted December 24, 2014 02:45 AM

HELP

This is really bizarre,
I deleted and re installed Hota and the updates at start box is unchecked to begin with and the unhandled exception no longer appeared but it loads to the 3DO screen and then goes Black, it hangs.
Got out of it and went shopping leaving the computer on. When I got back I had a look and the  the box remained un checked so I clicked the EXE and the game started. I got out of it and tried again, it started again and a third time so I played through the fisrt game and saved. Thought I had it working properly but when I shut down the computer and restarted, it hangs after the 3DO screen again. I tried changing the compatibility to XP, no luck, I ran it as administrator and no go, does any have any ideas its really strange.

____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
krs
krs


Famous Hero
posted December 24, 2014 04:38 PM

Did something happen to the legion artifacts? I find them overpriced.


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
nik312
nik312


Promising
Famous Hero
posted December 24, 2014 06:06 PM

krs said:
Did something happen to the legion artifacts? I find them overpriced.




Welcome to the Black Market. That's how it's always been there

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
nik312
nik312


Promising
Famous Hero
posted December 24, 2014 06:41 PM

Revdog said:
This is really bizarre,
I deleted and re installed Hota and the updates at start box is unchecked to begin with and the unhandled exception no longer appeared but it loads to the 3DO screen and then goes Black, it hangs.
Got out of it and went shopping leaving the computer on. When I got back I had a look and the  the box remained un checked so I clicked the EXE and the game started. I got out of it and tried again, it started again and a third time so I played through the fisrt game and saved. Thought I had it working properly but when I shut down the computer and restarted, it hangs after the 3DO screen again. I tried changing the compatibility to XP, no luck, I ran it as administrator and no go, does any have any ideas its really strange.



Where did you download HotA from and which OS do you run it on?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
krs
krs


Famous Hero
posted December 24, 2014 09:15 PM

nik312 said:
krs said:
Did something happen to the legion artifacts? I find them overpriced.

Welcome to the Black Market. That's how it's always been there


Never noticed that before. But shouldn't this get a fix? Looks like a 100% bug. The items in the window are already sorted according to their tier/price. And 12500 for legs of legion....

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Revdog
Revdog

Tavern Dweller
posted December 24, 2014 09:19 PM

nik312 said:
Revdog said:
This is really bizarre,
I deleted and re installed Hota and the updates at start box is unchecked to begin with and the unhandled exception no longer appeared but it loads to the 3DO screen and then goes Black, it hangs.
Got out of it and went shopping leaving the computer on. When I got back I had a look and the  the box remained un checked so I clicked the EXE and the game started. I got out of it and tried again, it started again and a third time so I played through the fisrt game and saved. Thought I had it working properly but when I shut down the computer and restarted, it hangs after the 3DO screen again. I tried changing the compatibility to XP, no luck, I ran it as administrator and no go, does any have any ideas its really strange.



Where did you download HotA from and which OS do you run it on?


From this site but I do have a working game now I down loaded Hota 1.3 and installed it over a clean Homm3 complete and it running like a dream. dont know why 1.3.3 wont work on my setup but ive given up trying now i have a working game
Thank you for your reply and a Merry Christmas to all
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Storm-Giant
Storm-Giant


Responsible
Undefeatable Hero
On the Other Side!
posted December 31, 2014 11:48 PM
Edited by Storm-Giant at 00:32, 01 Jan 2015.

HotA 1.3.4 bugs report (English version)

Satyrs placed in the map editor creates a graphic glitch:

When starting that map, it creates a couple of warnings:

...and they appear invisible (read: no graphic) after the game is loaded.

Further testing shows that it may be limited to satyrs placed in the map editor. In this pic one randomly generated appears without problem:


That map also crashed when placing all the new adv. buildings, but that's something best for the New Year

Edit: Satyr's dwelling provokes game crash.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
MattII
MattII


Legendary Hero
posted January 01, 2015 12:38 AM
Edited by MattII at 07:56, 02 Jan 2015.

Just checked with some of the new buildings in the map editor, and came across a possible fault in the Experimental Shop, the guards are given as 50 Iron Golems, than 100/150/200 Fire Elementals. Is this a typo, or is it actually set up like that?

Edit: Error updating is due to my previously running the program as a user, rather than an admin (ex business unit), and switching to admin fixed it.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Storm-Giant
Storm-Giant


Responsible
Undefeatable Hero
On the Other Side!
posted January 01, 2015 12:47 AM
Edited by Storm-Giant at 00:47, 01 Jan 2015.

It's a typo, the two banks I tried had 50 and 100 iron golemns
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
zreozer
zreozer

Tavern Dweller
posted January 01, 2015 01:15 AM

Hmm, I was reporting about this bug shortly after releasing v. 1.3.2, but it seems this issue still remains unresolved. On maps with "eliminate all monsters" victory condition, game doesn't recognise my winning when I cast Armageddon and all creatures on the battlefield dies. When it happens, victory is impossible - there is no monsters on map and the game doesn't see it! Bug appears both on "Trial of flame" map and on map created in map editor.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Datapack
Datapack


Famous Hero
posted January 01, 2015 03:57 PM
Edited by Datapack at 15:58, 01 Jan 2015.

MattII said:
Just checked with some of the new buildings in the map editor, and came across a possible fault in the Experimental Shop, the guards are given as 50 Iron Golems, than 100/150/200 Fire Elementals. Is this a typo, or is it actually set up like that?



Storm-Giant said:
It's a typo, the two banks I tried had 50 and 100 iron golemns


I stand corrected.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
krs
krs


Famous Hero
posted January 02, 2015 04:57 PM
Edited by krs at 09:43, 03 Jan 2015.

Big nix fort is generated on RMG HotA v1.3.5

Additionally I had 4! Nix forts in my zone and no other dwellings.


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
malax83
malax83


Famous Hero
Game ranger, HotA Player
posted January 03, 2015 01:29 AM

When i launch the map editor, i ve got a fatal error cause it need "editor.txt". I have full 1.3.5 version. Do i miss something ?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Docent_Picolan
Docent_Picolan


Adventuring Hero
posted January 03, 2015 02:05 PM

krs said:
Big nix fort is generated on RMG HotA v1.3.5

Additionally I had 4! Nix forts in my zone and no other dwellings.

it is not a bug, you probably just got lucky. Both versions (standard and large) are generated as a single object.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
krs
krs


Famous Hero
posted January 03, 2015 03:47 PM

its a bug, there is "no" amount of luck that gives you 4 nix forts and no other buildings.

here the next game I tried:



 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
nik312
nik312


Promising
Famous Hero
posted January 03, 2015 05:53 PM
Edited by nik312 at 17:54, 03 Jan 2015.

krs said:
its a bug, there is "no" amount of luck that gives you 4 nix forts and no other buildings.




What? No kidding? You just got 4 dwells of 6th lvl creature on Jebus and consider it impossible luck?)

I really want to see your reaction then after finding 7 dwells of green dragons or a dozen efreeti lakes in one zone

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
nik312
nik312


Promising
Famous Hero
posted January 03, 2015 05:58 PM

zreozer said:
Hmm, I was reporting about this bug shortly after releasing v. 1.3.2, but it seems this issue still remains unresolved. On maps with "eliminate all monsters" victory condition, game doesn't recognise my winning when I cast Armageddon and all creatures on the battlefield dies. When it happens, victory is impossible - there is no monsters on map and the game doesn't see it! Bug appears both on "Trial of flame" map and on map created in map editor.


This is how this win condition operated in the original game as well (it was there, though not available through the editor). There are many strange things about it which may be fixed later, but of all the original bugs this is not the most urgent  one

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 13 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0508 seconds