Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
HOMM1: info forum | HOMM2: info forum | HOMM3: info mods forum | HOMM4: info CTG forum | HOMM5: info mods forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 5 - Modders Workshop > Thread: How to change spell's visual??
Thread: How to change spell's visual??
romanov77
romanov77


Known Hero
posted October 22, 2007 03:10 PM

How to change spell's visual??

Guys, I have a problem.

Whenever I cast the Titan alternate special ability, my game slow down to a crawl, making the game almost unplayable... and being an Academy player, this really hurts. The blame is of course my crappy videocard.

So...is it possible to change the graphic effect of the ability, in order to get a better performance??

Please modders, I summon thee! Help me!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
sfidanza
sfidanza


Promising
Supreme Hero
posted October 23, 2007 02:09 PM

Did you first try to reduce your video settings in the game: Anti-aliasing and Anisotropic Filtering?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
romanov77
romanov77


Known Hero
posted October 23, 2007 03:03 PM

Quote:
Did you first try to reduce your video settings in the game: Anti-aliasing and Anisotropic Filtering?


Of course I did it...my videocard (ati x550) fares really bad with every smokey effects (I had similar delays throwing smoke granades in Call of Duty 2)

Im willing even to remove the whole titan alternate ability animation, as being an Academy player its a real pain in the arse.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
sfidanza
sfidanza


Promising
Supreme Hero
posted October 23, 2007 03:49 PM

I'll assume you know how to make a mod. Ask if anything is not clear.
I'll also assume you mean the effect on the target when the Storm Titan uses his Call Storm ability.

I think the files are in the folder:
GameMechanics\Spell\Creature_Abilities\Academy\
CallStorm.xdb is the entry point: at the end, you have a "visuals" tag:
<visuals>
<Item href="CallStorm.(SpellVisual).xdb#xpointer(/SpellVisual)"/>
<Item href="CallStorm_End.(SpellVisual).xdb#xpointer(/SpellVisual)"/>
<Item href="CallStorm_Hit.(SpellVisual).xdb#xpointer(/SpellVisual)"/>
</visuals>
referencing the 3 other CallStorm files in the folder. Try disabling the "effect" tag in those 3 files. Maybe remove a file's reference from the "visuals" tags, one file at a time, and you should find out which is causing the smoke effect.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
romanov77
romanov77


Known Hero
posted October 23, 2007 04:49 PM

Sfidanza, you are my hero, thanks for the interest!

However, Ive never modded anything!
I made search in the TotE folder, and found no "GameMechanics" folder...

I think I need a "Noobier" explanation

Anyway, Im happy that the thing can get fixed!!!!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Maurice
Maurice

Hero of Order
Part of the furniture
posted October 23, 2007 06:15 PM

Ahh, you need to unpack your data.pak file first, I'm afraid. There are several posts in this forum section that deal with unpacking stuff from the data.pak file, editing files, and assembling the changes into a mod again. Good luck!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
romanov77
romanov77


Known Hero
posted October 24, 2007 09:52 AM
Edited by romanov77 at 11:14, 24 Oct 2007.

Well, since I have PowerArchiver installed I managdd to open the data.pak....

LOTS of files in there...some just labelled "file" other "XDB" others "DDS"... NO FOLDERS AT ALL.

Now, Ive read the whole modding wiki and found no info on this:
Where the heck is the Gamemechanics folder?

EDIT:

Nevermind, powerarchiver sucks. got winrar and now I can see them.

I'll report if im not able to do it by myself.

Thanks!


EDIT 2:

Done!!! It works! I completely disablded the clouds which lagged the game! Thanks for the support guys!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Maurice
Maurice

Hero of Order
Part of the furniture
posted October 24, 2007 12:47 PM

Cool! Glad you fixed it .

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
romanov77
romanov77


Known Hero
posted October 24, 2007 10:39 PM

A final quick and easy question:

how can I disable the map objects glow? The yellowish glow on resources, mines....I think I could gain better fps without them...I disabled all light labeled entries in the .cgf file....which one controls this light??

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
sfidanza
sfidanza


Promising
Supreme Hero
posted October 25, 2007 07:30 PM

I'm not sure I understand which glow you're referring to. There's a
setvar gfx_dynamic_lights
entry in the user_a2.cfg file in your profile. Maybe you can try setting it to 0 and see if it does the trick.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
romanov77
romanov77


Known Hero
posted October 25, 2007 08:51 PM

Its the yellowish glow you see around resource piles and mines....Ive already put dynamic lights to 0...

I remember being able to remove them with the HoF tweaker...

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread »
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0252 seconds