Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
HOMM1: info forum | HOMM2: info forum | HOMM3: info mods forum | HOMM4: info CTG forum | HOMM5: info mods forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 5 - Modders Workshop > Thread: Texture/Effect issue
Thread: Texture/Effect issue
Sylannh
Sylannh

Tavern Dweller
Spinner of fates
posted November 17, 2020 05:41 PM

Texture/Effect issue

Hi everyone, here's my problem :

I recently created a new "FireSequence" texture for some of my new creatures' effects (Archangel and Thunder Thane). Though all seems to be working, when in combat I use the fireball spell, for some reason (I guess too many textures at a time), these effects suddenly disappear, or at least their FireSequence textures... Moreover, other units' effects I created (that are very similar) remain.
Leaving the game and relaunching it solves temporarily the problem, as well as changing the graphics quality. But whenever a fireball is launched, again, the effects vanish.
It seems that the game can't support the overflow of textures. But then why do the other effects remain ? And why can't I solve this by changing the graphics quality to minimum ? Please someone help me, I'm lost...

To illustrate, here are some pictures I took, before launching the fireball and after doing it. (You'll notice the black angel standing aside and his blade's effect are perfectly fine whatsoever)

http://www.mediafire.com/view/hwsuviys9kvm9sg/nobug.jpg/file
http://www.mediafire.com/view/ir9a3pthp3mvpf7/bug.jpg/file

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
xuxo
xuxo


Promising
Known Hero
posted November 18, 2020 10:47 AM

Could you upload the files of the units to investigate the effects? Surely you have duplicated the fire effects of the swords and replaced by lightning, maybe fireball and fire sword share some file and it makes that, when fireball is "off", the sword also. Without the files it is impossible to decrypt haha

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Sylannh
Sylannh

Tavern Dweller
Spinner of fates
posted November 18, 2020 07:00 PM

Sure !

Here it is, the .pak file for the angel (effects included) ; the Thane actually uses the same textures.
Your theory is interesting, but as I said, other modded FireSequence effects work regardless of the fireball, even if they were created with the same process (example : the dark purple fire seen in the previous pictures).

http://www.mediafire.com/file/7kd7fmmldcszkyn/NCF_207.pak/file

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread »
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0249 seconds