Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Library of Enlightenment > Thread: How can I solve my online-gaming problems exactly?
Thread: How can I solve my online-gaming problems exactly? This thread is 36 pages long: 1 2 3 4 5 ... 10 20 30 ... 32 33 34 35 36 · «PREV / NEXT»
snippao
snippao

Tavern Dweller
posted January 04, 2014 02:57 PM

How does it works to play HMM2?

It seems that i cant play it in game Ranger and i never find some1 to play in Tungle... =(

Any hamachi guy to play the legendary HMM2 against me? =)

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kuupora
Kuupora

Tavern Dweller
posted April 27, 2014 05:25 PM
Edited by Kuupora at 17:26, 27 Apr 2014.

Hello, I'm new in the forum. I wanted to register to share this information:

DirectPlay is not working well with UPnP. Heroes 3 uses DirectPlay and I believe this a major cause of connection issues. (This is true for my router Zyxel P870hn-51b, at least) My Heroes 3 game hosting succeeds always when UPNP is disabled in the router settings. When UPNP is enabled I can never find the host or my game can't be found. This is true for both LAN and internet games.

So if you have problems hosting / connecting to Heroes 3 games, here's what to do:

1. Disable UPNP in your router settings
2. Restart your pc

Also remember to do port forwarding and firewall exceptions and all that which is discussed in the post port of this thread. I am currently hosting a 3-player heroes game (tcp/ip) thru Hamachi, with no problems whatsoever. With Hamachi it's also important to select Hamachi as the primary network interface. (You can google this)


My 2 cents
Kuupora

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
King_V
King_V

Tavern Dweller
posted May 24, 2014 07:01 PM

Problems - Win7, TCP/IP, forwarded ports, Actiontec mi424wr rev i - still no g

Has anyone gotten this combination to work?

2 Windows 7 PCs
ActionTec MI424WR Rev I router
Each player using a non-Admin account on their respective PCs
HoMM3 Complete (GOG version)
LAN TCP/IP multiplayer game


The PCs IP addresses are:
192.168.1.4 (my PC)
192.168.1.2 (my son's PC)

I have installed the GOG version of HOMM3 complete on my Windows 7 machine, and my son's separate Windows 7 machine.  The game works in single player mode, no problem - don't even need Administrator permission to play it.

So, I found instructions on how to do port forwarding on this particular router, and set things up as follows.


On the router's Port Forwarding screen, I have:

Networked Computer/Device          Applications & Ports Forwarded          WAN Connection Type          Status
-------------------------------------------------------------------------------------------------------------------
192.168.1.4                        Destination ports 2300-2400             All Broadband Devices        Active
                                  TCP Any -> 2300-2400
                                  UDP Any -> 2300-2400

192.168.1.4                        Destination ports 28800-29100           All Broadband Devices        Active
                                  TCP Any -> 28800-29100
                                  UDP Any -> 28800-29100

192.168.1.4                        Destination ports 47624                 All Broadband Devices        Active
                                  TCP Any -> 47624
                                  UDP Any -> 47624



The behavior is really strange - but TWICE, however, it somehow worked.
One time was with my computer hosting, I manually typed in the IP address of the host on my son's computer, and the game played.
A second time (not right after), I had to use my son's computer to host, but I was able on my computer to click "Join" when his game showed up on he list, and it played.

Typically, however, neither scenario works.  Aside from those two successes, the game simply cannot connect via TCP/IP.  The usual behavior is that when I try to get the computers to start a LAN game with TCP/IP, when one hosts, the other will see the game show up on a list of hosted games.  However, clicking Join will cause it to wait for some time (mouse frozen, music still playing), and eventually a message coming up saying that it could not connect to the session, and to try again.

If I try to search via IP address, it will say the IP address isn't found.

What am I doing wrong?  I feel like I'm so close on this.  Right now I'm keeping a pair of WinXP machines just to play HoMM3 (via IPX protocol), but I'd rather decomission those old boxes and play this on the new PCs if at all possible.

I really want to get this working via TCP/IP reliably.  Hamachi hasn't worked for me, and I'd prefer to avoid additional software such as Hamachi, or GameRanger, etc.


As an aside, the way the Port Forwarding screen shows things, it almost seems to imply that the 192.168.1.4 machine always has to be the host when this game is being played - but is that actually true?  My two successes seem to imply not, though.


Thanks in advance for any help/guidance you can give - this is really driving me nuts!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kuupora
Kuupora

Tavern Dweller
posted June 01, 2014 08:32 PM

King_V: You do not need port forwarding since both of the computers are in the same lan.

Are the WinXP machines connected thru the same (ActionTec) router? Have you tried playing with the two WinXP machines using TCP/IP? (Because if that works then the router is not the problem)

Have you opened ports in both computer's firewalls? When you allow traffic to destination ports 2300-2400 and 47624 the source port has to be ANY port.

You could try installing Wireshark (http://www.wireshark.org/) to monitor the incoming / outgoing packets to see what's going on. Also check you firewall logs for blocked transmissions.

You could also check the router settings in order to disable UPNP.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
King_V
King_V

Tavern Dweller
posted June 03, 2014 10:40 PM

Kuupora,

At work now, so I can't really try it out - but even on WinXP, I could not play through TCP/IP.  I kept the WinXP machines around just to play it through IPX protocol.

But for Win7, that's not an option.

Neither Win7 nor WinXP works if I try to play a LAN game of HoMM3 in TCP/IP protocol.  I don't mind if I can't play online, I just want to be able to play on a LAN.

I have not looked at the Windows firewalls - I'm not really familiar with that at all, but I'll give it a look.  So you're saying I have to do the opening of ports at the Windows Firewall level?  Any specific ones, or the same ones that would normally be indicated with port forwarding?

Sorry for the confused-sounding questions.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kuupora
Kuupora

Tavern Dweller
posted June 04, 2014 12:29 AM

When a new program tries to form a connection from/to another computer, windows 7 brings up a dialog box in which it asks whether this program should be allowed to establish that connection. If you clicked "yes" at this point everything should be alright.

You can also check windows firewall's rules for HOMM3 in Control Panel -> Windows Firewall -> Advanced Settings -> Inbound Rules. I think Windows Firewall opens all the necessary ports as default when you click yes in dialog box or select allow in list view.

If you have an additional software firewall, you should open the ports 2300-2400 and 47624 there as well.



I think your problem might be the Universal Plug and Play feature in your router. I'd like you to try to disable it: the settings page should appear when you enter the address 192.168.1.1 in your browser.

http://screenshots.portforward.com/routers/Actiontec/MI424WR-GEN2_Rev_F/Universal_Plug_and_Play.htm

Just go to the Universal Plug and Play page an uncheck to upper box and click apply. Then restart your computer(s) and try the game

If the UPNP page is not there, try his

192.168.1.1/index.cgi?active_page=900


hope this helps
Kuupora

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
King_V
King_V

Tavern Dweller
posted June 13, 2014 02:42 AM

Thanks very much for the help!

Yep, the firewall rules were there - disabling UPnP (neither of the options sounded like an explicitly disabling UPnP, so I just unchecked both of them) seems to have done the trick.  Sort of.

Oddly, only my son's machine can host.  If I host, his machine never picks up the game in the game list (and won't find my machine if I enter my machine's IP address manually).  My machine, though, can automatically find any game his machine hosts.  Strange because it looks like all the settings are the same in both machines' rules for HoMM3 in the Windows Firewall inbound rules list.

The ONLY other difference I can think of is that, when I installed HoMM3 on my machine, I instead installed the Hi Res patch PRIOR to installing HoMM3, launched it - saw what was an unfamiliar screen to me, then tried to start in 1920x1080.  I then removed the hi-res patch, and installed HoMM3.  However, my son's machine shows it in normal aspect ratio, whereas mine still shows in 1920x1080.

No idea if that's affecting things in anyway - but I'm stuck with my machine not being able to host.

Thoughts?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kuupora
Kuupora

Tavern Dweller
posted June 13, 2014 06:37 PM
Edited by Kuupora at 19:05, 13 Jun 2014.

It's good to hear that you managed to get it working!

Sometimes routers have different settings for different LAN ports. Some ports might be configured to work as a separate group, and so on.

You could try to switch the LAN cable positions in the router ports. Thus you could find out whether this hosting problem is related to the router port or the computer itself.

The port that your computer is connected to might be set up to block outgoing broadcasts. HoMM3 uses TCP/IP broadcast (in other words, sending packets to the address 255.255.255.255) to announce the hosted game to all the computers in the same network.

http://www.verizon.com/cs/groups/public/documents/adacct/vz_bhr3_rev_i_user_manual.pdf

You could check the router manual for this. I don't so much about all these router settings but maybe some of these will help.

page 76. HW switch ports. (ingress and egress policies)
page 96. Firewall (LAN firewall especially)
page 100. Allow or restrict services.
page 110. Advanced filtering.

I'm not familiar with the Hi-Res patch. The wrong aspect ratio might be a display adapter or display adapter driver / settings related issue.




 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
King_V
King_V

Tavern Dweller
posted June 21, 2014 08:04 PM
Edited by King_V at 20:05, 21 Jun 2014.

First, let me thank you for all your help on this!

As to the current situation, here's what I have done since...


I tried using my old Windows XP machine with my son's new Win7 machine.

No problems. Either one could host.

Went back to the combo of my Win7 and my son's Win7, but the issues are the same as before.  My son could host, but if I tried, he'd never see my hosted game show up.

I went through the advanced firewall settings, and noticed that in the Outbound rules, my son's computer had both Home Group rules enabled, whereas those were disabled on my machine.

I enabled mine, to no avail.  Behavior is still the same.

I don't think it can be a router port issue.  I go from one of the physical ports on my Actiontec router to an unmanaged TP-LINK gigabit switch.  All the PCs I have go through the gigabit switch, to a single port on the ActionTec router.

In a sort of futile attempt, I changed which port my Win7 machine was plugged into on the switch.  No good.

So, I have some odd issue on my own PC that prevents others from seeing a game I host.

As a final test, I will later try my son's old WinXP PC in combination with my Win7 machine, and see what the results are.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kuupora
Kuupora

Tavern Dweller
posted June 23, 2014 11:05 AM

Ok, let's get back to the assumption that the problem is computer specific!

I'd like you to check which network connection is primary: Control Panel -> Network & Sharing Center -> Change Adapter Settings (left panel) -> Press Alt -> Advanced -> Advanced Settings.

Use the up&down arrows to arrange the list.

In an earlier post you say that Hamachi hasn't worked for you. Usually when Hamachi is in use, it should be on top of this list. If Hamachi is not in use, Local Area Connection (wired connection) or Wireless Network Connection should on top. Anyways, you should have the same settings on your computer's list as in your son's computer's list.


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kuupora
Kuupora

Tavern Dweller
posted June 26, 2014 02:14 PM

King V: There has to be some kind of difference between the two Windows 7 computers. You could run "ipconfig /all" on command prompt (on both win 7 computers), take screenshots and post the results here.

An additional thought: Do you have an additional antivirus/firewall? I have sometimes had problems with the Comodo Internet Security antivirus&firewall, which is notorious for meddling with other programs' functionality. If you have you could disable them while trying to get the game working. . .


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Rallyket
Rallyket

Tavern Dweller
posted July 02, 2014 12:12 PM

Hello

Just a few days ago me and a friend played Heroes 3 over hamachi and it worked for both, we found eachother by searching the hamachi IP in the game and got connected and could play.
I had Windows 7 ultimate 64bit then and he had windows 8 pro 64bit, both had the same hamachi version,the same heroes 3 version and we were both in the same network on hamachi.

But then the problems started, i decided to upgrade to windows 8.1 pro 64bit and installed hamachi and followed all the instuctions. I found the game he hosted in Heroes 3 in Tcp\Ip even without searching, it just popped up but i was unable to join it, just got at error message up about timing out. Tried disabling the firewall,forwarding the ports on my router but nothing helped.
I have also tried reinstalling Heroes3 and Hamachi and changed networks but still the same problem.
So i decided to install windows 7 ultimate 64bit again since it worked the last time we played, but im having the same problems i had i windows 8.1 pro 64bit, i find the game in tcp\ip but im unable to join it because it times out.

Anyone have a solution to this problem or is it very random ?
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
kuupora
kuupora

Tavern Dweller
posted July 02, 2014 03:02 PM
Edited by kuupora at 21:15, 02 Jul 2014.

Hello Rallyket,


Since you managed to get the game working before, the problem is not likely to be a router or a port forwarding issue. To me it sound like the initial handshake (goes thru port 47624) works and thus you can see the game in the list. Then when the actual game data is to be sent thru ports 2300-2400 the packets get lost.

There are couple of things I'd like you to check:

1. Hamachi has to be the primary network adapter (see my post June 23rd)

2. Check that windows firewall has the right executable selected for allowing Hamachi traffic.

Open Windows firewall,

Click "Allow a program or feature through Windows Firewall" (left panel),

Select Hamachi Client Tunneling Engine from the list (If it's not in the list click Allow another program ...)

Click Details, check that "Path" refers to the executable "C:\Program Files (x86)\LogMeIn Hamachi\hamachi-2.exe" (Choose the right path for your installation folder, of course) If hamachi-2-ui.exe is selected it might not work. In order to change the target file, click Allow another program ...

Also see that Home/Work/Public network boxes are checked in the list.

3. If you have an additional firewall you have to open ports there as well. (destination port=2300-2400 TCP/UDP, source port=any and destination port 47624 TCP/UDP, source port=any)

4. If you had previously configured Hamachi to use static ports you might want to do this now as well. Also open these ports in any 3rd party firewalls you have.

5. Is UPNP disabled in your router? If not, disable it.

6. Can you start multiplayer game with other computers than your friend's? If so, then the problem is caused by your friend's system. Also, if your friend can start mp game with other computers than yours, then your system is causing the problem.



 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Rallyket
Rallyket

Tavern Dweller
posted July 02, 2014 10:00 PM

I have tried and done all the things you listed and more things as well but still doesnt work.
The strange thing is that it didnt work just by changing OS.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
kuupora
kuupora

Tavern Dweller
posted July 02, 2014 10:47 PM

It is strange indeed. Have you tried restarting your router? Can you host/join TCP/IP games in LAN?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Rallyket
Rallyket

Tavern Dweller
posted July 02, 2014 10:52 PM

I have not tried restarting my router.
And i havent tried the other option either.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Rallyket
Rallyket

Tavern Dweller
posted July 02, 2014 11:02 PM

Tried restarting my router but still didnt work.
And we are playing through TCP\IP in heroes3.
But not i cant see his games anymore.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
kuupora
kuupora

Tavern Dweller
posted July 02, 2014 11:33 PM

This really sounds like an inconsistent problem.

Is your friend also connected through a router? Try to boot that too. By LAN game I meant playing with other computers that are directly connected to the same router, within the same household.

When you connect each others with Hamachi do you get the green dot icon (direct connect) or the blue (relayed connect)?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Rallyket
Rallyket

Tavern Dweller
posted July 02, 2014 11:36 PM

We always get green dots on hamachi.
It shouldnt have anything to say that hes behind a router because we played and it worked the same day, but when i installed a new OS it didnt work. He hasnt changed anything on his computer.
And no i havent tried LAN cus i dont have anyone else in this household.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
kuupora
kuupora

Tavern Dweller
posted July 02, 2014 11:50 PM

Ok, so, just to check one basic thing: When you start HOMM3, New Game -> Multiplayer -> TCP/IP and the game now shows your IP address on top the list, is you IP like 25.xxx.xxx.xxx as in Hamachi address space? Or is it 192.168.xxx.xxx?

The reason I asked you to try to boot your friends router too is that something that I don't understand is going on... as you say you can't see his game anymore, I mean what's the reason for that? It could be anything, especially as you haven't changed firewall rules since you last could see his game. And as I understand from your posts, you have done everything necessary to make the game work. So why not boot the router? I'm running out of ideas...

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 36 pages long: 1 2 3 4 5 ... 10 20 30 ... 32 33 34 35 36 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.1182 seconds