Heroes of Might and Magic Community
please log in.! Register | Today's Posts | Search! | FAQ/Rules | AvatarList | MemberList | Profile

<a href="http://www.game-advertising-online.com/" target=_blank>Game Advertising Online</a><br> banner requires iframes

Heroes 1 (Heroes 2 (Heroes 3 (Heroes 4 (Heroes 5 (Heroes 6 ()

Login:     Username:     Password:    
Heroes Community > Library of Enlightenment > Thread: How can I solve my online-gaming problems exactly?
Thread: How can I solve my online-gaming problems exactly? [ This thread is 34 pages long: 1 2 3 4 (5) 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 ]
Tc_Fear
Tc_Fear


Famous Hero
posted January 31, 2005 06:01 PM

seems like time fixes that
____________
'the only thing necessery for the triumph of evel is for good men to do nothing'
Edmund Burke

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
aZtraL
aZtraL


Hired Hero
posted February 18, 2005 08:09 AM

my problem was number 5 i will see if it works now, good guide mate

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
LKru33
LKru33


Promising
Famous Hero
3x NFL Pick'em Champ
posted March 11, 2005 09:10 AM
Edited By: lkru33 on 11 Mar 2005

I am currently having a problem hosting a game on the zone.  I recently installed a wireless router (Linksys) and I suspect that has something to do with it.  I am, however, still able to play games on the zone where someone else is hosting.  

If my problem is a router issue.... would it be possible for me to be able to play games on the zone at all (games where I am NOT the host)?

Previous to my installing the wireless router, I was able to host games without any problems.  

I am currently running Heroes 3 complete (ver. 4.0)

My opponents are also running 3 complete or similar
____________

 Send Instant Message | Send E-Mail | View Profile | PP | Quote Reply | Link
angelito
angelito

Hero of Order
proud father of a princess
posted March 11, 2005 12:04 PM

Lkru33...watch this "clips" to see how u can set your Linksys router on DMZ (De Militarized Zone)
http://zonesysops.com/clips/dmz.html

After that, u should be able to host and join
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
tigris
tigris


Supreme Hero
Supreme Noobolator
posted March 14, 2005 02:57 AM

i have downloaded the automatic autosaver from here, but can't figure out how to make it work exactly. Anyone knows?
____________

 Send Instant Message | Send E-Mail | View Profile | PP | Quote Reply | Link
LKru33
LKru33


Promising
Famous Hero
3x NFL Pick'em Champ
posted March 14, 2005 07:48 AM

Quote:
Lkru33...watch this "clips" to see how u can set your Linksys router on DMZ (De Militarized Zone)
http://zonesysops.com/clips/dmz.html

After that, u should be able to host and join


Hey, this worked like a charm.  I am now back up and running  Great detail on the instruction!!  Thanks again.
____________

 Send Instant Message | Send E-Mail | View Profile | PP | Quote Reply | Link
Kaspar9233
Kaspar9233

Tavern Dweller
posted March 24, 2005 04:37 PM

It gets Complicated

Well, first off, I just want to say I am new to the community. I was directed to this thread by another member. I have tried many things to solve my problem, but alas I have reached the end of my rope. lol. I am reaching out to anyone who might have an answer to my problem. I have tried to host as well as play HOMM3 with my father over the Zone. It doesn't seem to matter wether it is him or me hosting. First we both updated our Heroes. We both have Restoration of Erathia, and we updated to 1.4 version. Which we thought was originally our problem. Well it may have been one of them. Well, next I thought that maybe it was my router. Since I do not know much about routers, I decided to unplug it and and disconnect my 2nd computer from the internet so that I may be able to play with my father. (he's at another location then me) Well, this didn't work. And finally we both disabled our firewalls, and still neither one of us could host a game. When either one of us tried to host a game, we would launch the game and it would bring us to a screen that says New Game or Load Game, we would click on New Game, and go in and pick a game...while the other person would sit at the main screen of HOMM3 (the archangel with the flaming sword) and the cursor would be in the hourglass shape and it wouldn't allow us to join the game. Then after a few minutes of waiting, it would say "Error in launching, please try again" (maybe not those same words but close). Now I am not quite sure what else to do. But any positive feedback I can get would be greatly appreciated. HOMM3 is driving me crazy. lol.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
angelito
angelito

Hero of Order
proud father of a princess
posted March 24, 2005 05:40 PM

Would be interesting how u tried to connect to your dad. Direct-connection?, IP?
If u have dsl and use a dsl-network card, u have to open some specific ports to be able to connect. (i mentioned them in this thread here, also check out how to forward ports when playing behind a router)
Gimme some more infos please, so we can check out other solutions..

____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kaspar9233
Kaspar9233

Tavern Dweller
posted March 25, 2005 07:54 PM

Well, to respond to your questions, we tried to hook up via direct connection, IP, as well as through the Zone. We couldn't get it to work any of those ways. I am not very smart when it comes to routers, and some of those tutorials on routers confuse me even more. lol. I probably need to become more router saavy. But, I recently learned of another problem that it may be. My father told me that he recently got a wireless router for him and my mother to both have internet access. (oh and by the way, I don't have dsl, I have regular cable internet. I am thinking I won't probably be able to play homm3 online with other people, but I am very glad if you have any suggestions to help me Angelito. Thank you for taking the time to read these, and respond. I appreciate it.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
patriot_pulsar
patriot_pulsar


Adventuring Hero
posted April 14, 2005 08:09 AM

Man first never unplug the router becaus then when u will put it back on u will make problem even more complicated (did it once) All ur settigs will go on 0 so u will need to start everyting again. Second which router u have?? And take ur time everything is fixable it took me 3 days to fix my router but then i realised how easy it was. If u will be coming in zone today look for me after 4pm Uk time i am always there maybe i can help my name Ww_Val_wW. Gl with  ur problem hope u can fix it heroes needs new player because game is old and more and more players leave us.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Munzai
Munzai

Tavern Dweller
Always coming, never arrives..
posted April 22, 2005 05:34 AM

Adding ports to your firewall(s) should solve all connection problems, for online gaming.
Also check Configuration Screen, at ur Start Menu, for any weird programs, could be some 2nd hand security prog.
If still doesn't works, try disabling your AntiVir program. Only when u wanna play ofcourse.
But keep ur standart windows firewall on (just add the correct ports at firewall options)
The standart windows firewall can be found at networklocations, then right click properties--> goto the firewall tab, and add UDP AND TCP ports.
Goodluck

ps. isn't as much work as it looks.

Ajú
____________
-|<"ThreeTwoOneSixSeven">|-

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Munzai
Munzai

Tavern Dweller
Always coming, never arrives..
posted April 22, 2005 05:37 AM

This counts for most online-playable games by the way.
____________
-|<"ThreeTwoOneSixSeven">|-

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Motto
Motto

Tavern Dweller
posted May 14, 2005 07:29 AM

Yet another problem...

We have a similar problem with our heroes. I reinstalled and updated the game. When attempting to play on the zone i end up in the main menu without further action. We have yet to test letting the intro run, and playing a few days consistently.

When trying tcp/ip however an error message appears:
______________________________________________

DirectPlay Error:

'Unknown error?'

File 'C:\Dev\Heroes 3 Exp 2\Game\Remote.cp¨p'
Line#1867
______________________________________________

Heroes is installed in the default /program/3DO folder, the dev folder is a ghost as far as im concerned. Does DirectPlay mean directx is spooking or what?

Any help is appreciated. Thx.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
themegaNewbie
themegaNewbie

Tavern Dweller
posted May 15, 2005 12:57 PM

First of all sorry for my english. Now the questien.

Im not under the LAN, I dont have any routers/switches/hubs etc i want to play on-line with my friend, and host the game, I did everything that is in this FAQ and its still dont work(I did, He didn't, He is behind router but even if?Im the one who host the game so even if he have all ports blocked and 10 Firewalls turned on, it doesnt matter right, cause Im hosting the game right) So what do you think? Im sure everyting its ok for me so is it possible that he cant CONNECT because of the router problem?

PSh and one thing, both of us have Armageddons Blade v.2.1 cause its impossible to update id to 2.2(after pathing the game the exe file is still in 2.1, even if I run the path in the heroes directory)
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
angelito
angelito

Hero of Order
proud father of a princess
posted May 15, 2005 02:08 PM

First of all, u have to know that Armageddon´s Blade can´t be played on the zone. Only Heroes 3 original and the addons can be played there (they ALL have the same exe-file...that´s why). AB is not really an addon, but a game by it´s own. You have to play this game through TCP/IP connection.
About your patching problem.....
First of all, be sure you use the RIGHT patch. There do exist TWO patches for AB. 20to22 and 21to22. If your version is 2.1, you have to use the second one (i only mention that, coz sometimes the solution is just that easy..). If u did it that way and it doesn´t work, there are 2 possibilites which could cause that problem.
1. You are using a "non-english" version of AB.
2. Your version is corrupt.

Solution: After you used the patch, normaly all needed files were updated but the exe file not. So u have to find the patched exe-file and just replace it with your 2.1 exe. After that, it should work.

Good luck

____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
themegaNewbie
themegaNewbie

Tavern Dweller
posted May 15, 2005 04:23 PM

yep , now it works! All files have been updated but not exe file, I found 2.2 exe file @ kazaa and its works. Wooho thanx man.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
angelito
angelito

Hero of Order
proud father of a princess
posted May 15, 2005 04:25 PM

You´re welcome
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
tigris
tigris


Supreme Hero
Supreme Noobolator
posted May 25, 2005 05:04 PM

i had a odd problem when trying to enter the zone these days:When selecting heroes from the cd-rom games and then when faced with the "downloadind and installing latest version screen" the whole thing just freezed.No progress was shown.

Here is how this problem is solved, just in case anyone finds himself in the same situation:

1.Close all Internet browsers.Open control panel,then click on network and internet connections, then internet options

2.Once there, you have to delete all cokies.selectgeneral from the upper list, then, delete cokies

3.next to that you have delete files click on that too.It will remove all your internet temporary files.

this should usually do it, but if it still doesn't work you may want to check if the site isn't by chance blocked.In order to do this you must select from the internet options the privacylabel, then if the zone appears on the blocked sites list just allow it.

well hopes this helps a bit.It sure helped me
____________

 Send Instant Message | Send E-Mail | View Profile | PP | Quote Reply | Link
Jebus
Jebus


Promising
Supreme Hero
TheJester akaJeebs akaJebfoo
posted May 31, 2005 03:57 PM

We should change the name of this thread to
"Angelito's online gaming problem one stop chop teck shop!!"  (say that 5 times fast!!)



(I'd like to thank Angel for the time he spends helping out wether it be on the zone or right here at home)

J
____________
"You went over my helmet??"

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Motto
Motto

Tavern Dweller
posted June 02, 2005 07:38 AM

The problem

Well iv been poking around in my direct x concerning the problem mentioned earlier and found that there are two directplays: Directplay8, which is fully functioning, and directplay, to which the drivers are missing.

Having directX 9 i have tried uninstalling it (which wasnt easy) and installing directX 8 but it fails to install the older directplay drivers which i assume heroes 3 needs for network play.

So... does anyone know how i can get hold off the missing files? Or how one can uninstall direct x 9 and substitute it with a direct x version prior to 8? I really dont want to give up on this but its pretty messed up...

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
[ This thread is 34 pages long: 1 2 3 4 (5) 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 ] < Prev Thread . . . Next Thread >
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0584 seconds