Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
HOMM1: info forum | HOMM2: info forum | HOMM3: info mods forum | HOMM4: info CTG forum | HOMM5: info mods forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Turban Tribunal > Thread: AOH & HC Moving to a New Server
Thread: AOH & HC Moving to a New Server This thread is 4 pages long: 1 2 3 4 · «PREV / NEXT»
Geny
Geny


Responsible
Undefeatable Hero
What if Elvin was female?
posted December 27, 2014 08:41 AM

I don't know if it's because of the move or some previous changes, but many thread names in the Glade are missing. I tried looking for them via members' profile pages, but they are missing from there as well. As far as I could see this problem exists only in the Glade.
____________
DON'T BE A NOOB, JOIN A.D.V.E.N.T.U.R.E.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
artu
artu


Promising
Undefeatable Hero
My BS sensor is tingling again
posted December 27, 2014 01:20 PM

Some new posts dont show up on Last 10 Replies thread until you edit them, also similarly, threads that are 2 pages show up as a single page or threads that are 26 pages show up as 25 pages because the main page does not display the last posts until you click on the threads themselves.
____________
Are you pretty? This is my occasion. - Ghost

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Storm-Giant
Storm-Giant


Responsible
Undefeatable Hero
On the Other Side!
posted December 27, 2014 02:10 PM
Edited by Storm-Giant at 14:25, 27 Dec 2014.

artu said:
also similarly, threads that are 2 pages show up as a single page or threads that are 26 pages show up as 25 pages because the main page does not display the last posts until you click on the threads themselves.

It is even less than that. H3 HD announcement thread is 16 pages long yet it shows page 15 on the last posts. It shows correctly browsing through the forum though.

Edit: This thread is 2 pages long yet it only shows the first page on Today's Posts. Yikes
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Stevie
Stevie


Responsible
Undefeatable Hero
posted December 27, 2014 03:51 PM
Edited by Stevie at 15:54, 27 Dec 2014.

Recently posted in that thread and my reply doesn't show in the last 10 Replies section. After I clicked submit I didn't waited for the confirmation message but went to the main page immediately, maybe that's what's causing it.

Edit: Did it again on this thread and it's exactly as I said above, clicked submit and didn't waited for the confirmation.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Valeriy
Valeriy

Mage of the Land
Naughty, Naughty Valeriy
posted December 27, 2014 08:19 PM
Edited by Valeriy at 20:32, 27 Dec 2014.

Thanks for the reports, I'm looking into it. Can see the glade error and the error with incorrect number of replies / incorrect last poster on index and forum display pages. Let me know if you notice any more patterns about these errors.

EDIT: Did a quick fix to correct thread reply counts, but still need to find what is causing the problem in the first place. It doesn't seem to happen when I post a reply.
____________
You can wait for others to do it, but if they don't know how, you'll wait forever.
Be an example of what you want to see on HC and in the world.
http://www.heroesofmightandmagic.com

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted December 27, 2014 08:52 PM

From what I saw it occurs because two reasons:

a) probably this one now: you post once, it appears twice. You delete one, but index remains +1.
b) when moderator deletes posts, index does not change.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Valeriy
Valeriy

Mage of the Land
Naughty, Naughty Valeriy
posted December 27, 2014 09:57 PM

Fixed the no title threads in Glade issue. Also fixed searching for quoted search strings (problem that first appeared after server upgrade on the previous host).

Yet to look into the post count / last poster update issue. Do keep posting your observations of when it does / doesn't trigger - this is helpful.
____________
You can wait for others to do it, but if they don't know how, you'll wait forever.
Be an example of what you want to see on HC and in the world.
http://www.heroesofmightandmagic.com

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Galaad
Galaad

Hero of Order
Li mort as morz, li vif as vis
posted December 28, 2014 01:27 AM

This post I made didn't trigger. I've edited it, and we see me as last replier but doesn't appear on main page.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Valeriy
Valeriy

Mage of the Land
Naughty, Naughty Valeriy
posted December 28, 2014 03:22 AM

I made a tweak in the post reply function fixing some code that may have been causing this issue. Let me know whether it fixes the problem. If not, I'll do more thorough debugging.
____________
You can wait for others to do it, but if they don't know how, you'll wait forever.
Be an example of what you want to see on HC and in the world.
http://www.heroesofmightandmagic.com

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
mvassilev
mvassilev


Responsible
Undefeatable Hero
posted December 28, 2014 04:39 AM
Edited by mvassilev at 05:44, 28 Dec 2014.

I currently have to access this page through the link at the AOH front page because heroescommunity.com redirects to this page.

Edit: This problem seems to have gone away.
____________
Eccentric Opinion

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Doomforge
Doomforge


Admirable
Undefeatable Hero
Retired Hero
posted December 28, 2014 11:25 AM

I really like how smooth the new server is
____________
We reached to the stars and everything is now ours

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Maurice
Maurice

Hero of Order
Part of the furniture
posted December 28, 2014 01:49 PM

First time I've visited here since Christmas hit the world, but I have to make a compliment here. Yes, a few issues seem to have cropped up, judging by the replies here, but Val, you sure are smashing them as soon as you can! But do reserve some time for that holiday feeling, ok?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Galaad
Galaad

Hero of Order
Li mort as morz, li vif as vis
posted December 28, 2014 05:16 PM
Edited by Galaad at 16:20, 29 Dec 2014.

Yes I too feel the website's upgrade
However, I still have to edit a post after posting for it to appear as last reply.

Edit : Also, it was gone for a short time but it appeared again, when I submit post reply, I am not redirected to the thread, even though the reply was correctly posted.

Edit 2 : Seems to be fixed
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Valeriy
Valeriy

Mage of the Land
Naughty, Naughty Valeriy
posted December 28, 2014 08:26 PM
Edited by Valeriy at 20:29, 28 Dec 2014.

Yes, there seems to be some DNS update oddness happening. When updating the DNS I've flicked it through the parked domain nameservers, and it seems that this data is also circulating through the internet. Today I'm seeing some generic "under construction" page when I go to heroescommunity.com. DNS system is a bit lame if after a few days it is still circulating non-current records... Let's see if this goes away naturally.

Glad that you're enjoying the speed guys. It also gives me a sense of satisfaction to re-use some server admin and optimization skills I've developed in my previous job.

I still have to move AOH and there is a disk space problem cropping up on the old web host. This problem is outside of my control due to limited access and the web host does not respond to any messages, so I've got some time pressure if I want to avoid problems. Don't worry though, it's a bit like a game for me at the moment and I'm having fun with it.

The "reply not updating thread/forum" bug is puzzling - it doesn't happen for me, and when it happens it doesn't leave any traces in any of the server error logs. So let's try a different strategy. When you post a reply you will see a little string of text on the very top of the page, it will look like: "TEST:Valeriy1234567". Copy this string when you make a reply and post it here if that reply produced an error. (redirect only gives 2 sec, so you will have to be quick or quickly stop the page when it redirects).
____________
You can wait for others to do it, but if they don't know how, you'll wait forever.
Be an example of what you want to see on HC and in the world.
http://www.heroesofmightandmagic.com

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Storm-Giant
Storm-Giant


Responsible
Undefeatable Hero
On the Other Side!
posted December 28, 2014 08:43 PM
Edited by Storm-Giant at 20:47, 28 Dec 2014.

Just like this morning, posting on the Movie thread gave me some 'minor' problem.

When I click the Submit Reply button, it starts loading for like 20 seconds before showing the following:

Quote:
Error Code: 500
Description: Internal Server Error

Please try again or return to Heroes Community Home Page

It never reaches to the redirect page. The post does make through, although it doesn't show on Today's Posts (neither browsing through the forum) until I edit that post.

Edit: And for the record, this post went without any problems. Nor at Flanking thread on H7 forum. However I had the same problem when posting on HotA thread
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Valeriy
Valeriy

Mage of the Land
Naughty, Naughty Valeriy
posted December 28, 2014 09:14 PM
Edited by Valeriy at 22:32, 28 Dec 2014.

Thanks, SG, I finally managed to reproduce the error by posting in the movie thread. And I found the problem - the e-mail notification function is not working properly. (So don't worry about the test string above). I've disabled e-mail notifications for now and will see if I can make them work.

UPDATE: Solved the problem and re-enabled e-mail notifications. Replying should update everything properly now. Note: if you sent any e-mails using the HC's send e-mail function since the server move, they wouldn't have gone through. E-mail function also works now.
____________
You can wait for others to do it, but if they don't know how, you'll wait forever.
Be an example of what you want to see on HC and in the world.
http://www.heroesofmightandmagic.com

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Orzie
Orzie


Responsible
Supreme Hero
posted December 29, 2014 06:24 AM

I noticed the forum started loading much faster.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
mvassilev
mvassilev


Responsible
Undefeatable Hero
posted December 29, 2014 08:10 AM

The redirect problem is happening again.
____________
Eccentric Opinion

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Gnomes2169
Gnomes2169


Honorable
Undefeatable Hero
Duke of the Glade
posted December 29, 2014 08:12 AM

I've got the image problem, and I also can't see any of the emoticons or "New topic/ post" buttons. Anyone else have that second problem?
____________
Yeah in the 18th century, two inventions suggested a method of measurement. One won and the other stayed in America.
-Ghost destroying Fred

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kareeah_Indaga
Kareeah_Indaga


Responsible
Undefeatable Hero
posted December 29, 2014 10:50 PM

I had issues editing my profile when I had my profile picture set to 'None.' If I tried to change my signature I'd get the message "Invalid avatar selection. Please backup and select another avatar." It went away when I selected an avatar, but the forums have never cared that I didn't have one before.
____________
Adventures in Helnith has moved!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 4 pages long: 1 2 3 4 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0381 seconds