Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 5 - Temple of Ashan > Thread: ~ HELP Topic - Heroes 5: System Requirements, Computer Problems and Troubleshooting ~
Thread: ~ HELP Topic - Heroes 5: System Requirements, Computer Problems and Troubleshooting ~ [ This thread is 48 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 (44) 45 46 47 48 ]
Knayr
Knayr

Tavern Dweller
posted March 09, 2011 08:24 PM

Hey all,

I'm currently re-downloading my D2D installer(s) as well as the 11.2 ATI Catalyst package.  I am hoping that reinstalling and/or updating drivers will resolve some of these things, but figured I'd post here to see if these were known problems.

Here are my issues:

1.  It feels like the animations for the trees and the NPC/Hero circles are very slow or incomplete.  The circles that appear under heroes and NPCs seem to rotate in five or ten degree intervals, rather than spinning smoothly around the hero/NPC.  I'm not sure if this is working as intended, but it gives the impression of a poor framerate even if all of the other animations are butter-smooth.  The sway of the trees is also choppy and slow-looking.

2.  Water textures flicker in and out in a very clear pattern, alternating between smooth, spotty, horizontally lined, and vertically lined.  I've attached three images to show what I mean.





I'm running:
Windows 7 Home Premium (64bit)
Phenom II 1090T (3.2GHz)
Asus M4A88TD-V Evo
4GB DDR3 1600 (PC3 12800)
Sapphire RadeonHD 5830

There's no reason why this game should give my system any trouble.

Thanks for reading,

--K

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
undead_assault
undead_assault


Adventuring Hero
Armageddoning
posted March 10, 2011 06:40 AM

hmmm, hi @Knayr

I think ToE has some problem in Windows 7. Your PC configuration is overkill. I'm afraid you must installed it in Windows XP to enjoy ToE the most.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Knayr
Knayr

Tavern Dweller
posted March 10, 2011 08:05 AM

UA,

Thanks for the reply.  I updated my ATI drivers and it seems to have resolved most of the issues!  The water texture is fixed, and the circle animations are smooth again.

Mission accomplished!

--K
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Elvin
Elvin

Hero of Order
Stillness within Movement
posted March 10, 2011 08:07 AM


____________
So the next time your cat leaves a bleeding, twitching corpse on your doormat, remember that she loves you and is just trying to bring out your inner predator.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
DoubleDeck
DoubleDeck


Promising
Legendary Hero
Look into my eyes...
posted March 10, 2011 09:54 AM

For Heroes V Tribes to work on Windows 7, it's simple:

- Install game.
- Download 3.1 patch and install.
- Update graphics card drivers.
- Play the game!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
kodaghost
kodaghost

Tavern Dweller
posted March 10, 2011 10:22 PM

Quote:
My PC:
Athlon64@3000+ (socket 754)
GeForce FX 5200 - 256MB
1GB RAM (@400)
WinXP - Service Pack 2

My view - I had no experience on closed beta:
I was expecting it much faster. These are the settings I use:
1024x768,
High Resolution,
Antialiasing full,
A bit of Anisotropic filtering,
and No Eyecandies UNchecked.
Overall I think it's OK but HEAVY, though my time goes by pretty well - I think the main suspect for this is that it is simply a new interesting game. But if I have to think of a multiplayer version of it ... ... seems like a joke! Even more, if time limits are going to be applied!

By the way,
Quote:
So i will need someone senidng me "Angelitos Fiesta vs 1.11" when my new comp will be delivered (tuesday evening).
I always share it on my ftp! Just IM me on tuesday evening and I 'll send you my IP to get it!

____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
undead_assault
undead_assault


Adventuring Hero
Armageddoning
posted March 11, 2011 01:37 AM

Quote:
UA,

Thanks for the reply.  I updated my ATI drivers and it seems to have resolved most of the issues!  The water texture is fixed, and the circle animations are smooth again.

Mission accomplished!

--K


Hi Knayr, I'm curious but didn't you have the latest version of ATI driver already?

Just a minute ago I checked in their website, and the latest version is still 11.2

So, the problem is not in Windows 7 but in Windows 7 64 bit...I still suffer crappy graphics in ToE with Win7 64 bit

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
DoubleDeck
DoubleDeck


Promising
Legendary Hero
Look into my eyes...
posted March 11, 2011 05:10 AM

Quote:


Hi Knayr, I'm curious but didn't you have the latest version of ATI driver already?
Just a minute ago I checked in their website, and the latest version is still 11.2
So, the problem is not in Windows 7 but in Windows 7 64 bit...I still suffer crappy graphics in ToE with Win7 64 bit


I am using Windows 7 Ultimate 64 bit and it's working fine (Core 2 Duo 2.66 Ghz, 4 GRam, Geforce GTX 260)...

Obviously you have installed the 3.1 patch....the only other thing I can think of is I bought the latest Heroes V in the shops called the "Gold Edition" with all three Heroes V games....somehow this worked for me as they are latest editions, I was having troubles playing the original Heroes V Tribes DVD on my Windows 7....

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
mihealloroa
mihealloroa

Tavern Dweller
posted May 24, 2011 07:20 PM

Memory stick capable memory card reader helps the consumer to copy pictures taken from Sony digital camera to the computer.
____________
iPad 2 covers

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
regnak
regnak

Tavern Dweller
posted May 30, 2011 08:25 PM

Ok I got a new PC 2 weeks ago and ordered the HOMM 5 epic collection. I started playing last Friday and everything ws going fine until today. I get to the the last battle of the 2nd mission of the Inferno campaign and near the end of the battle I get a message:

"Heroes of Might and Magic V has stopped working. Windows is checking for a solution to the problem." Then another windows pops up that says:

"A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available."


This is version 1.5 and I am running Windows 7 64 bit. Any ideas?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Elvin
Elvin

Hero of Order
Stillness within Movement
posted May 30, 2011 09:05 PM

Bug, have you tried a previous save? Restarting the mission may help.. You could also try 1.6 patch but you may have to restart the mission anyway.
____________
So the next time your cat leaves a bleeding, twitching corpse on your doormat, remember that she loves you and is just trying to bring out your inner predator.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
regnak
regnak

Tavern Dweller
posted May 30, 2011 09:14 PM

Well I tried it a 3rd time and it did not crash. So I guess something trying to update might have done it?

I looked at the 1.6 patch but it did not say anything about this problem so I decided to wait.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Elvin
Elvin

Hero of Order
Stillness within Movement
posted May 30, 2011 09:20 PM

It's a mess really.. Some patches crash at points, others do not or crash in different points I must be one of the few that never encountered a bug during H5. Sad to see so many people having to restart a mission
____________
So the next time your cat leaves a bleeding, twitching corpse on your doormat, remember that she loves you and is just trying to bring out your inner predator.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
nilen111
nilen111

Tavern Dweller
posted June 01, 2011 06:55 AM

heroes 5 closes when loading

hi everyone.well i just downloaded the heroes 5 demo and install it.the game loads but when it is either loading a campaign or a custom game it closes.my pc info are:

processor:Intel(R)Pentium(R)dual CPU E2160 @1.80 ghz  
memory 2038 ram
direct x 9.0c
CHIP TYPE :Intel (r)GMA 3000--128mb

Can anyone please help me.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
nilen111
nilen111

Tavern Dweller
posted June 01, 2011 06:56 AM

heroes 5 closes when loading

hi everyone.well i just downloaded the heroes 5 demo and install it.the game loads but when it is either loading a campaign or a custom game it closes.my pc info are:

processor:Intel(R)Pentium(R)dual CPU E2160 @1.80 ghz  
memory 2038 ram
direct x 9.0c
CHIP TYPE :Intel (r)GMA 3000--128mb

Can anyone please help me.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
andrei74
andrei74

Tavern Dweller
posted June 08, 2011 03:27 PM

Heroes V of Might and Magic 1.0

   Ok so I was playing the game, I was Necropolis, my enemy was Haven. I played for about 1 hour, I made a big city, nice army prepared for my hero. Next I saw an enemy hero aproaching, his army was small, about 30 elven archers and about 20 sworddancers(not sure about the name), he just walked up to my main city ( witch had all defensive upgrades) and took over it with no fight. i decided to go to the town with my main hero but no hope, I had to destroy it's defenes, Is that normal?  I was playing singleplayer on a multiplayer map ( the 8 player one, Warlords).

I couldn't get the patches because there is a problem with my internet, If anyone can enlighten me, please do it.







Thanks.  

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
DoubleDeck
DoubleDeck


Promising
Legendary Hero
Look into my eyes...
posted June 09, 2011 06:39 AM

Guys, remember you should have no problems with Heroes as long as you have the latest graphics card drivers updated and the latest Heroes Patch (very NB):

Heroes V - Patch 1.6
Heroes V HoF - Patch 2.01
Heroes V Tribes - Patch 3.1


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
JeanAHough
JeanAHough

Tavern Dweller
posted June 27, 2011 11:50 PM

Need help?

Quote:
I think that maybe a growing number of Heroes V players using Windows 7 will have trouble starting the game because they are missing the d3dx9_25.dll file. I made a detailed post on this issue on Ubisoft's tech forum for Heroes V, and I am duplicating it here. If the moderator of this forum thinks this is inappropriate, please delete it.

1. Do a Web search for d3dx9_25.dll
2. You should get at least a couple of hits that direct you to a site where you can download the d3dx9_25.dll file.
2. To access d3dx9_25.dll from the downloaded file, you will probably need to unzip the file. Windows 7 does that automatically by simply double-clicking on the download. (I don't remember for sure, but I think that Windows XP and Windows Vista may also automatically unzip it.) Otherwise you'll need an application like WinZip to unzip it.
3. After opening up the downloaded file (that is, after unzipping it), highlight and copy the d3dx9_25.dll file. Then go to your Heroes of Might and Magic V folder. If you did the default installation, this file will be in your Ubisoft folder. If you have the Tribes of the East expansion installed, in addition to the Heroes of Might and Magic V folder your Ubisoft folder will also have a Heroes of Might and Magic V - Tribes of the East folder.
4. In your Heroes of Might and Magic V folder(s), you will have at least one bin file. If you have the Hammers of Fate expansion installed, your Heroes of Might and Magic V folder will have a bin file and a bina1 file. Open up each of those bin files and paste the d3dx9_25.dll file that you have downloaded and copied. If you have Tribes of the East installed, your Heroes of Might and Magic V - Tribes of the East folder will have a bin and a binDM file. Again, open each of those bin files and paste the d3dx9_25.dll file.

That's it. Your game should now start up.

Note: I have seen other forum posts regarding d3dx9_25.dll. I don't remember if I saw those posts here or in the forums at Celestial Heavens and Heroes Community. I do remember that those posts suggested that you simply install DirectX during the game's installation process. That will install the d3dx9_25.dll file in your Heroes of Might and Magic V bin folder(s). I did not want to do that, however, because I think I should have the most recent version of DirectX, which is DirectX 11, not DirectX 9.0c (installed by the game). You may run into trouble with other applications if you don't have the most recent version of DirectX. Also, I don't trust another poster's suggestion that it's okay to have two versions of DirectX installed.

You should install the most recent patches. As of this post, they are version 1.6 for Heroes of Might and Magic V, version 2.1 for Heroes of Might and Magic V - Hammers of Fate, and version 3.1 for Heroes of Might and Magic V - Tribes of the East. I think you can get all those patches from the Ubisoft site. If not, check forums at Celestial Heavens and Heroes Community. Your version of the game can be seen by opening the game and proceeding to the main-menu screen. Check the corner. Warning!!! -- Be sure to install the correct regional version of the patch. As did I, you might think you need the US version when you actually need the EU (European) version. (See my other post, titled "Patches are not recognizing my installation of Heroes V."





http://www.d3dx9.net/download-missing-d3dx9_25-dll/
You can get the d3dx9_25.dll file from the above link.
this is the source which is best for solving this sort of dll related issues.
Click the Link on this page “Run a Free DLL Scan” and it will fix it for you.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
JeanAHough
JeanAHough

Tavern Dweller
posted June 28, 2011 07:49 PM

Quote:
Hey Guys! Got a question: Is it normal that the game runs smooth as hell for a minute and then got delay like im playing a high-end game?
Well I guess not but I hope you folks can help me out somehow, donno why its like that.
I got a
GeForce 9500M GS with 512 MB Ram with an
Intel Core 2 Duo T8300 2.4 G, and
4 GB Ram

so folks, looking at how smooth it works every minute and looking at my specs I guess im safe when I say it should work fine!
Drivers are also up to date, well the date which is possible for a notebook.

So tell me please! What can I do??


Hello solipso,

Try to follow these steps:
d3dx9_25.dll
This is because you are missing a file.
Step 1. You can download here.
Step 2. Paste this file into your system32 and system folder. Also put it in your syswow
Step 3. Navigate to your System32(32Bit OS) or SyWOW64(64Bit OS) Folder.
Note: The location of System32 or SyWOW64 is
C:Windows\System32 (If you are using 32Bit Windows)
C:\Windows\SysWOW64 (if you are using 64Bit Windows)
Step 4.Paste the d3dx9_25.dll into this folder.
Step 5.Run the game. It might work now.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
DoubleDeck
DoubleDeck


Promising
Legendary Hero
Look into my eyes...
posted July 05, 2011 11:27 AM

I also had this d3dx9_25.dll problem at first but not anymore.

Try re-installing the game, the exe file should be "run as administrator" then install the right patch (eg tribes 3.1).

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
[ This thread is 48 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 (44) 45 46 47 48 ] < Prev Thread . . . Next Thread >
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.1145 seconds