Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: Adding new creatures
Thread: Adding new creatures This thread is 15 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 · «PREV / NEXT»
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted February 14, 2011 07:01 AM

Well, there is no "one click" way to add what we could not during 10 years. It requires knowing some technical things about how Heroes process defs, pics, codes.
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 15, 2011 02:23 AM

Okay, can you post what erm code exactly did you write to add that new creature?
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted February 15, 2011 03:45 AM

ZVSE

!#HE$:C0/0/197/1;
$=your hero ID
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
ddpro
ddpro


Known Hero
HC Adventurer From China
posted February 15, 2011 04:22 AM
Edited by ddpro at 04:23, 15 Feb 2011.

Never do I use ERA
____________
A jewel is just a pebble that found a way to shine.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted February 15, 2011 04:26 AM

Well, you will
The old wog is no more in download, at least for us. ERA is offering so many more possibilities. And the fact that this pluggin not yet working has nothing to do with ERA.
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
ddpro
ddpro


Known Hero
HC Adventurer From China
posted February 15, 2011 05:03 AM

Quote:
Well, you will
The old wog is no more in download, at least for us. ERA is offering so many more possibilities. And the fact that this pluggin not yet working has nothing to do with ERA.

Thanks
I'll try ERA as soon as I have time to do that. By now I'm still a little too busy to try pluggins for WoG
____________
A jewel is just a pebble that found a way to shine.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 16, 2011 05:06 AM

How do you import a script into a wog map?

I am of course, trying to import the adding-creature-197-to-hero script but I get error message everytime I try to put it in as a .txt file.

Help ~~
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
solitaire345
solitaire345


Promising
Famous Hero
posted February 16, 2011 09:49 AM

Copy the contents of txt file into a timed event in the map. And make sure that the first line contains letters ZVSE. Also you can set it's occurence day to something high to avoid message box with your script
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 17, 2011 03:12 AM

so I put the following in Day 1 of a map. As a test, I put gave a hero 1 archangel but nothing happened. I don't even need era for this so clearly I didn't do something right.

ZVSE

!#HE146:C0/0/13/1;

The above code was put into the message box but the game didn't give me an angel. The hero I put in is #146 (Catherine).


____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Aleee
Aleee


Known Hero
posted February 17, 2011 06:33 AM

Make sure that ZVSE isn't the title of the message box. Its place is exactly in the box. Also you'll need Catharine standing on a map at the very beginning of the game (set up in the editor).
In general, this piece of code is correct. Something is wrong with the way you integrate it in a particular map.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted February 17, 2011 08:14 AM
Edited by Salamandre at 08:28, 17 Feb 2011.

The code will not work if you checked "customize" in armies. Leave your hero as it comes from editor and set the time event to day >300 to be sure you don't see the code popping.
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Aleee
Aleee


Known Hero
posted February 17, 2011 02:29 PM

Oh, right. If you do need customization you can use a post-instruction instead of an instruction.

ZVSE
!?PI;
!!HE146:C0/0/13/1;

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted February 17, 2011 02:32 PM

Why would anyone need custom armies when scripting with HE$:C0
It is the same thing
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Aleee
Aleee


Known Hero
posted February 17, 2011 02:41 PM

Well, I used it once. There was a window for the password at the beginning of the map (right after PI-trigger) and in case it was correct I used HE:C, otherwise standard settings were active. Of course it can be done with HE:C only, but I was following the line of the least resistance (and the least amount of code). And also I've just showed our newcomer what post-instruction is.

These are lame excuses, right?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 19, 2011 12:08 AM

Okay, it seems like the amethyst.cfg is now causing some problems to the WOG. Wog won't even run at all when the above-mentioned cfg is in the data folder.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 19, 2011 12:45 AM
Edited by bbvsdd at 01:35, 19 Feb 2011.

Okay I've got the script uploaded and now at least I can see creature 197 being added, but I have to put creature numbers in amethyst.cfg back to 196 or else WOG won't run.

However, I run into an error every time immediately after combat loaded:

Attempt to divide an integer value by an integer divisor of zero.

The Latest Executed ERM Receiver:

IF&v997=0:V786/0; //if asmodeus sends devils there will be no random hero

!?BG0&781/v846=1/1000;

Looks like the creature stats were all 0s.....

Is it because the config was set to 196 that WOG won't pull the last line of zcrtrait.txt?

How can I get this to work if WOG doesn't even RUN when amethyst.cfg is set to 197? double-clicking on h3wog.exe produce absolutely no reaction.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted February 19, 2011 02:19 PM

Quote:
double-clicking on h3wog.exe produce absolutely no reaction.

Add some empty strings to ZCRTRAIT and CRANIM

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 19, 2011 10:53 PM

I already added an entire line to those two files with full animations copied from dracolich etc. but the game still doesn't run...
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted February 19, 2011 11:41 PM
Edited by Salamandre at 23:42, 19 Feb 2011.

I don't get what is so hard:

1) Required: ERA version, on WoG 3.58 WILL NOT WORK.
2) Add the files from OxFea pack in the recommended folders
3) Increase "Creatures" value in DATA/amethyst.cfg
3) Use my code to add the creature

Nothing more.
____________
All my Era II mods

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bbvsdd
bbvsdd


Hired Hero
posted February 20, 2011 12:41 AM

1) Done
2) Done
3) WOG Won't run if creature number is 197 in that cfg. It runs no problem if the number is 196
4) Done

You see a problem?
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 15 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0323 seconds