Heroes of Might and Magic Community
please log in.! Register | Today's Posts | Search! | FAQ/Rules | AvatarList | MemberList | Profile

<a href="http://www.game-advertising-online.com/" target=_blank>Game Advertising Online</a><br> banner requires iframes

Heroes 1 (Heroes 2 (Heroes 3 (Heroes 4 (Heroes 5 (Heroes 6 ()

Login:     Username:     Password:    
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: Adding new creatures
Thread: Adding new creatures [ This thread is 13 pages long: 1 2 3 4 5 6 (7) 8 9 10 11 12 13 ]
kiladesu
kiladesu

Tavern Dweller
posted June 04, 2011 06:15 AM

in adding new creatures, what does "flags" mean?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted June 04, 2011 07:02 AM

Quote:
in adding new creatures, what does "flags" mean?

Monster's flags, of course. See MA:X in ERM-help.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
xypicur
xypicur

Tavern Dweller
posted June 04, 2011 12:42 PM
Edited by xypicur at 09:08, 13 Jun 2011.

Quote:
Quote:

Thank you OxFEA, the second problem was fixed, but how to fix my def files?
I cant find the problem in it.

Can you upload it?
I'll try to use it.


Here is the .def file:
link

And here is the .gif file:


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted June 04, 2011 02:24 PM

Hm, it works normal.
Other defs works fine?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
xypicur
xypicur

Tavern Dweller
posted June 04, 2011 05:04 PM
Edited by xypicur at 09:06, 13 Jun 2011.

Quote:
Hm, it works normal.
Other defs works fine?


the amethyst is works fine, but with this ogre:



seems nothing:


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
KevinHann
KevinHann


Adventuring Hero
posted July 12, 2011 08:37 PM
Edited by KevinHann at 05:36, 13 Jul 2011.

I'm sorry for the stupid question, but how do I actually edit the CPRSMALL.def, TWCRPORT.def and AVWATTAK.def? I have the 32x32 bmp image of the new creature I'd like to put in, I exported CPRSMALL from the current h3sprite.lod, opened it with def preview and exported all images from it for def tool. I then loaded them in def tool... and that's all. I have no idea how to add the extra image, how to rename it, what to do with it.

What do I actually do with the freaking thing


Edit: Ignore that, I found out after a cigarette break. Silly me.

Edit2: Epic fail. Followed all steps, opened map editor and found my new monster 197 there. Everything seemed fine except the editor called it "archmage" even though I didn't put that name anywhere (it's the yao bear from F3). Placed it in a map to test and ran the game.

While it was loading, got two separate error messages:

"Could not load mask file for yaoadv1.def! - Type: Monster"

"Invalid Object referenced!
x:34 y:56 z:0 - Type: Monster"

And when I entered the game, the bear on the map seemed weird - only a portion of it was showing, as if the image I loaded was too big and the game cut a piece of the corner to put it in.

Sadly, that was the only sign of my bear. It appeared as archmagi when interacted. Tried to combat it and it appeared as archmagi on the battlefield as well - name, stats and everything.

Seems I managed to do quite a few things wrong. Will need to figure what's not ok with the size of the used images, and how the hell the game interpreted my monster as a tower unit with no reference at all.
Time for another ciggy break to cool down.

Edit3: okay, I've got a breakthrough. All problems were because I somehow missed to create .msg and .msk files for the adventure map def via Def Tool. Played a bit until I discovered that. (at one point I imagined it could be because of something shadow-related and manually drew shadows in the bitmaps to just discover the program does that much better than me within a couple clicks of the mouse ) I then had to open advanced properties of the monster in the editor and manually type in the subtype 197 as it wouldn't let me pick it from the dropdown menu. The monster is now clearly visible on the editor, as well as in game - but it appears under the name "null". Will have to look into that.

Of course, this lead to yet another setback. When I entered the game and engaged the monster in combat, the game dropped a few messages about ResourceManager::GetSample could not find the "sfx" resource "(null)move.82M" - and a few more .82M related missing resources, eventually leading to an unsurprising "Access violation" dialog, dropping me out of the game. Another ciggy and I'll try to handle that one, too.

Digging into this can be a pleasure when you actually manage to overcome some obstacles, too bad I don't have efficient free time to progress to a serious level like you, guys. It only makes me respect you more.

Edit4: Okay, the initial problem is definitely linked to the sounds, but I can't figure why the game looks for the sound files under these specific names. I did rename all the sound files so that they match the missing resources, manually changing the extentions from .wav to .82M - just to see what happens. The game no longer displays messages about missing resources, it just gives the access violation message and crashes. Disappointing, I'm running out of ideas what's causing it. It has now been a whole night trying to resolve this.

Edit5: Giving up for the moment, can't think of anything. Will go out for a cup of coffee which I desperately need. I'm sure it is something small I can't find because of ignorance...

Edit6: Well, finally cracked it. It wasn't out of ignorance, even though I don't feel any less stupid. It isn't mentioned in the first post of the thread, nor in the instructions, so I never realized I had to find, download and put in the plugins folder amethyst.dll before I can even think of adding new creatures. Amazed I got this far without it

Still some issues, like second new creature (198) not displaying in the map editor and error messages when moving the cursor over stacks placed on a map in the editor, but I'm generally satisfied now. Worth the effort

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted July 13, 2011 06:38 AM
Edited by OxFEA at 07:10, 13 Jul 2011.

Quote:
Amazed I got this far without it

I too. BTW, what dll you used - from first page or from sixth?
Quote:
like second new creature (198) not displaying in the map editor and error messages when moving the cursor over stacks placed on a map in the editor

I don't touch the map editor, so, it doesn't support new creatures. I forgot about it, sorry.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
KevinHann
KevinHann


Adventuring Hero
posted July 13, 2011 07:31 AM

Quote:
BTW, what dll you used - from first page or from sixth?
like second new creature (198) not displaying in the map editor and error messages when moving the cursor over stacks placed on a map in the editor.

I don't touch the map editor, so, it doesn't support new creatures. I forgot about it, sorry.


It is weird, because the first new creature appears there, the one after doesn't.

I downloaded it from another thread:

http://heroescommunity.com/viewthread.php3?TID=35577

If it is not up-to-date, I'd appreciate a fresh link. The link you posted lead me to a missing file, I figured it could have expired or something.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted July 13, 2011 08:06 AM

http://df2.ucoz.ru/2011/05/19/281824663-1305810895.rar

Use amethyst.dll from this archive.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
KevinHann
KevinHann


Adventuring Hero
posted July 13, 2011 08:28 AM

Quote:
http://df2.ucoz.ru/2011/05/19/281824663-1305810895.rar

Use amethyst.dll from this archive.


Alright, will do.

What's different in it?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted July 13, 2011 10:27 AM

Quote:
What's different in it?

Bugs fixed.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
KevinHann
KevinHann


Adventuring Hero
posted July 13, 2011 11:25 AM

Hmm it doesn't have install guide, I just extracted the two dll's in my ERA folder, hope I didn't miss anything.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kegolo
Kegolo


Promising
Famous Hero
of infamy
posted July 16, 2011 03:32 PM

Quote:
Quote:
What's different in it?

Bugs fixed.


I'm not sure if this is a bug or not, but can the new creatures not be upgraded in a town? I tried adding creatures 197-210 to a town using UN:T, setting them as part of that town using MA but when I try MA:U it does not work. It does work if I stick a random creature below 196 in, then I can go say MA:U100/200 that works. Any clue why the other doesn't?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted July 17, 2011 02:49 AM

Quote:
Any clue why the other doesn't?

Thnx for report, I'll try to fix it.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted July 17, 2011 05:36 AM

Fixed: http://df2.ucoz.ru/2011/07/17/643828221-1310893721.rar

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Kegolo
Kegolo


Promising
Famous Hero
of infamy
posted July 17, 2011 11:25 AM

Quote:
Fixed: http://df2.ucoz.ru/2011/07/17/643828221-1310893721.rar


Wow thanks worked like a charm!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Misterio
Misterio

Tavern Dweller
posted July 26, 2011 07:07 AM
Edited by Misterio at 08:35, 26 Jul 2011.

nice
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Misterio
Misterio

Tavern Dweller
posted July 26, 2011 08:33 AM
Edited by Misterio at 08:35, 26 Jul 2011.

Quote:
nice
but complicated to instal
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
solitaire345
solitaire345


Promising
Famous Hero
posted July 28, 2011 03:16 AM
Edited by solitaire345 at 07:06, 28 Jul 2011.

Quote:

- add sounds: S[number]ATTK.82m, S[number]SHOT.82m and others.



Is it possible to make loading sounds not from .\data ditectory, bur from any of the lod files?

EDIT: also, in creature experience window creature's portrait isn't shown

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
OxFEA
OxFEA


Promising
Famous Hero
feanor on DF2.ru
posted July 28, 2011 11:04 AM

Quote:
but complicated to instal

I think that text "if you see it complicated - you don't need it" definitely needed.

Quote:
Is it possible to make loading sounds not from .\data ditectory, bur from any of the lod files?

Use heroes3.snd and MMArchive or any other program?
Quote:
EDIT: also, in creature experience window creature's portrait isn't shown

WoG dialogs is buggy, yes, I know.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
[ This thread is 13 pages long: 1 2 3 4 5 6 (7) 8 9 10 11 12 13 ] < Prev Thread . . . Next Thread >
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0625 seconds