Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
HOMM1: info forum | HOMM2: info forum | HOMM3: info mods forum | HOMM4: info CTG forum | HOMM5: info mods forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 5 - Modders Workshop > Thread: Heroes 5.5 - Eternal Essence - Bugs and Known Issues"
Thread: Heroes 5.5 - Eternal Essence - Bugs and Known Issues" This thread is 14 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 · «PREV / NEXT»
TheBaron
TheBaron


Promising
Known Hero
dreamer of dreams
posted June 03, 2011 06:43 AM

What I mean is; have you downloaded the Quantomas' AI patch? Have you downloaded any other user made modifications for the game? If not, you may want to seek help on another thread that addresses troubleshooting for the 'vanilla' (meaning non user-modified) version of the game. You can probably find that in the normal Heroes 5 section, rather than this section, which is specifically for customisations made by fans.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fester
fester


Adventuring Hero
posted June 06, 2011 10:16 AM

In 3.1c it seems that when going for info on heroes it crashes. Played som different maps and had crashes when right clicking other heroes. 2 times on adventure map. 1 with a random hero in battle while rightclicking him. Also 1 crash in town in buy hero page just as i where about to check hero for additional info.
Also anothor minor thing i noticed is that the startscreen seems to be fixed for 1024x768. I got 1366x768 and the dialouge was like iŽd set the screen for 1024x768, it also affected the choicesliders in the custommap dialoge. No biggie. However those 3 checks for 8 skills etc dont change when clicking them. there is a sound but the boxes remain checked.
My setup is win7 x64, h5 latest ver + rpe ed.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
TheBaron
TheBaron


Promising
Known Hero
dreamer of dreams
posted June 06, 2011 10:21 AM

Quote:
My setup is win7 x64, h5 latest ver + rpe ed.


tribes of the east or vanilla h5?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fester
fester


Adventuring Hero
posted June 06, 2011 11:26 AM
Edited by fester at 12:19, 06 Jun 2011.

Quote:
Quote:
My setup is win7 x64, h5 latest ver + rpe ed.


tribes of the east or vanilla h5?


ToE ... Now I seen it crashes just by hovering the mouse over heroes on the map, 1 crash in town in buy heroes page just by selecting the second of the two heroes available for buy.

EDIT : all herocrash things, seems to be on specific heroes i e hoovering mouse one heroes is okay but crashes on the another.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
TheBaron
TheBaron


Promising
Known Hero
dreamer of dreams
posted June 06, 2011 12:17 PM

i have the same setup and mine's fine. i suggest a reinstall and if it's still not working write back.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
uberdanish
uberdanish

Tavern Dweller
posted June 06, 2011 04:54 PM

To Fester & The Baron,  I play the regular ToE Campaign. Version 3.1. I uninstalled and I am replaying the the whole campaign.  Won't know until I complete the next chapter if it crashed again.
Thanks, for responding.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fester
fester


Adventuring Hero
posted June 07, 2011 05:15 AM

x hours later...
Just finished "heritage" on a new install without RPE (plz make it work plzplzplzplzpzllz ). No crazy crashes round the clock. Exept for the multitasking thing , going back is always a 1/3 prob to crash. Maybe EE or just maybe h5 on win7 x64.
One of my dudes (lethos) got nine skills. Had 8 and ran into a witch hut and got an additional leadership. It did not show with the other eight just on levelup like when showed for being upgraded etc. It also affected my attributes like it whould normally so it was the "real" deal just "invisible". Talk about jack of all trades  

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
TheBaron
TheBaron


Promising
Known Hero
dreamer of dreams
posted June 07, 2011 05:54 AM

Quote:
Maybe EE or just maybe h5 on win7 x64.

Have you tried running in compatibility mode and as administrator? This may help. Windows 7 is not friendly to this game.


Quote:
One of my dudes (lethos) got nine skills. Had 8 and ran into a witch hut and got an additional leadership. It did not show with the other eight just on levelup like when showed for being upgraded etc. It also affected my attributes like it whould normally so it was the "real" deal just "invisible". Talk about jack of all trades  

This is an important issue I think. Perhaps Cepheus or Quantomas can address this.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Hellglory
Hellglory


Hired Hero
posted June 07, 2011 06:08 AM

I'm still getting crashes when loading games with the new release.  If it helps to know, the loading bar will hit 50% progress everytime (when it does crash) then freeze-> desktop.  I've seen no pattern.  Number of loads, in and out of battle, time in game, all of these have varied and still getting the crash maybe 1 in 5 loads on average.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fester
fester


Adventuring Hero
posted June 07, 2011 07:29 AM
Edited by fester at 07:34, 07 Jun 2011.

@baron : Im running it in winxp sp2 comp. havnŽt set ALL exe in the dir to that just the 3.1c exe.

EDIT:
@Hellglory : Tell us your setup. OS, game version etc. with/without mods...

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Quantomas
Quantomas


Responsible
Famous Hero
AI Wizard
posted June 07, 2011 10:28 AM
Edited by Quantomas at 10:32, 07 Jun 2011.

The reason I have taken out the NCF/RPE 999 fix (3.1.8) is that it somehow corrupts game states.

My advice to get to a cleanly running setup:

1. Remove all savegames from 3.1.8 and all savegames after 3.1.8 was installed, even if these are from 3.1c. The reason is, they can import a corrupted game state again.

2. Do a complete uninstall.

3. Make sure that all the folders in the Program Files/Ubisoft/Heroes of Might and Magic V – Tribes of the East/bin are empty (better delete these)

4. On Win7 you also need to clean Users/*/AppData/Local/VirtualStore/Program Files (x86)/Ubisoft/Heroes of Might and Magic V - Tribes of the East. Win7 keeps virtual copies there, for everything changed w/o admin rights (total idiocy the security design of Win7).

5. Clean your Users/*/Documents/My Games/Heroes of Might and Magic V - Tribes of the East/Profiles. Store your savegames, replays, screenshots (everything you would like to keep) in another place, then delete.

6. Reboot.

7. Complete reinstall of ToE, plus the official 3.1 patch.

8. Do not install mods.

9. Install 3.1c. Copy the H5_AIadv_31c.exe and H5_AIProcess.exe to the /bin folder, the EE_options.pak to the /data folder.

It should run absolutely cleanly on Win7, don't change admin rights, compatibility mode or anything. I also contribute the ninth skill bug to a corrupted setup, unless this can be confirmed on a clean setup.

@Hellglory
I am currently testing Axis of Evil 2.1 with 3.1c on Win7 x64 ultimate edition. Being well into month two, it runs absolutely smoothly. Sounds a bit like you have somewhere a version mismatch, the H5_AIProcess from a different release instead of the newest one or something like that.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
magnomagus
magnomagus


Honorable
Legendary Hero
modding wizard
posted June 07, 2011 10:40 AM

@Quantomas

Thanks for clarifications,

I have found another bug, if quick combat is activated pressing the replay combat button makes the neutral guardians dissapear.

For balance reasons I also highly recommend to change the neutral guardians not to have any destructive magic.
____________
MMH5.5 Downloads | MMH5.5 Translations | MMH5.5 FAQ

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fester
fester


Adventuring Hero
posted June 08, 2011 07:51 AM
Edited by fester at 08:32, 08 Jun 2011.

I followed your removal instructions step by step, even user\local stuff too (it was already empty) but I checked it. I even ran regedit and delete anything that was in regards to h5 in any way. rebooted. Installed fresh with no mods at all ,unpacked the h5 3.1c into gamedir so all folders match. and that was it.
Current map is "Shadow Dreams TOE". This time i got a slots full and I go into a pyramid. After victory I got logistics as 9th skill. This time I haveŽnt seen it in the levelupugrade yet.

EDIT : I got an unavoidable crash now http://www.sendspace.com/file/jlw0ie (9th skill hero is the first)

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Hellglory
Hellglory


Hired Hero
posted June 09, 2011 09:32 PM
Edited by Hellglory at 21:38, 09 Jun 2011.

Quote:
@Hellglory : Tell us your setup. OS, game version etc. with/without mods...


Win7 64 with the latest stable release 3.1c with no mods


Quote:
@Hellglory
I am currently testing Axis of Evil 2.1 with 3.1c on Win7 x64 ultimate edition. Being well into month two, it runs absolutely smoothly. Sounds a bit like you have somewhere a version mismatch, the H5_AIProcess from a different release instead of the newest one or something like that.


I've deleted old saves, double checked AI files, and even removed all downloaded maps but still getting the crash on loading saved games.  I would add I've had this minor issue with the last couple beta iterations as well.  However, if I am the only one getting this then the problem perhaps it's localized to my setup somehow.  I would say this crash isn't a huge deal and doesn't happen enough to stop me from playing but I'll try to fish around to locate the issue myself if possible.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
PyroStock
PyroStock


Adventuring Hero
posted June 10, 2011 08:49 PM
Edited by PyroStock at 20:53, 10 Jun 2011.

3.1c Hotseat

3.1c on WinXP
No other mods ever used.
No problems ever w/ 3.1b on Hotseat MP.

1>Moving MP Hotseat maps from ToE3.1 to 3.1c games results in those games moving from 'racial skill + 5other skills' to 'racial skill + 6other skills'.  I suspect this will be true in Hotseat MP maps from 3.1b to 3.1c too.  Perhaps this is somehow connected to the "9th skill bug" mentioned elsewhere also, but in this case it is the "7th skill bug".

2>The additional options for 3.1c are only displayed through the Singleplayer Custom Setup not offered in the Multiplayer Hotseat Setup.  However, these additional options still appear listed in multiplayer hotseat settings (and possibly apply?) with the following forced defaults:

Lookahead Depth: Normal
Neutral Champions: Hard
Hall of Decision: 28days (not active, so no problem for now)
Artefact Guards: Yes
Taxes: No
Hero Skills: 8

Multiplayer Hotseat Workaround appears to be to go to Single Player - Custom then set desired 3.1c options and you must hit Create.  Then Backup into Multiplayer Hotseat and continue.  The 3.1c options selected in SinglePlayer will be listed in the Multiplayer Hotseat.

I never used 3.1.8 or 3.1.9, but is a complete uninstall/reinstall necessary to use 3.1c?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Quantomas
Quantomas


Responsible
Famous Hero
AI Wizard
posted June 11, 2011 12:42 AM

Quote:
3.1c on WinXP
No other mods ever used.
No problems ever w/ 3.1b on Hotseat MP.

1>Moving MP Hotseat maps from ToE3.1 to 3.1c games results in those games moving from 'racial skill + 5other skills' to 'racial skill + 6other skills'.  I suspect this will be true in Hotseat MP maps from 3.1b to 3.1c too.  Perhaps this is somehow connected to the "9th skill bug" mentioned elsewhere also, but in this case it is the "7th skill bug".

2>The additional options for 3.1c are only displayed through the Singleplayer Custom Setup not offered in the Multiplayer Hotseat Setup.  However, these additional options still appear listed in multiplayer hotseat settings (and possibly apply?) with the following forced defaults:

Lookahead Depth: Normal
Neutral Champions: Hard
Hall of Decision: 28days (not active, so no problem for now)
Artefact Guards: Yes
Taxes: No
Hero Skills: 8

Multiplayer Hotseat Workaround appears to be to go to Single Player - Custom then set desired 3.1c options and you must hit Create.  Then Backup into Multiplayer Hotseat and continue.  The 3.1c options selected in SinglePlayer will be listed in the Multiplayer Hotseat.

I never used 3.1.8 or 3.1.9, but is a complete uninstall/reinstall necessary to use 3.1c?

The workaround you described is correct. This properly applies the settings in multiplayer.

You don't need to do a reinstall if you never used 3.1.8.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
PyroStock
PyroStock


Adventuring Hero
posted June 13, 2011 01:28 PM
Edited by PyroStock at 23:18, 13 Jun 2011.

Scrolls and Wands and Invisibility

3.1c on WinXP
No other mods ever used.

1>The scroll bug still exists.  All scrolls are not cast at advanced level, but as if the player has no skill level at all.  This contradicts the player manual 3.1 and in-game description.  I am not sure if this is a bug in the original ToE 3.1.

2>Wands are correctly cast at the advanced level with power 8 (as described in the player manual).  However, every time a hero flees with a wand the "wand" is permanently added to the hero's spell book twice without requiring the use of an inventory slot.  I am not sure if this is a bug in the original ToE 3.1.

edit:
3>I can see where an invisible enemy unit moves because it's quantity number appears while it moves.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
stachnie
stachnie


Known Hero
posted June 15, 2011 08:50 AM

3.1.9 beta @ Win XP, map: Ultima Classic

I started the game with 3.1.8 beta but I had up to now no remarkable problems with 3.1.9. Sometimes AI heroes behaved in a strange way (they were going across whole map until the AI process hanged, probably after entering a whirlpool) but it was possible to avoid that after a reload or two.

Now I have a similar situation but the crash is unavoidable - probably because AI heroes have no other way to escape. There is only one AI left, it is down to one town and my very strong secondary hero has landed near the last AI town. The save is
here.

S

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Quantomas
Quantomas


Responsible
Famous Hero
AI Wizard
posted June 15, 2011 07:45 PM

Quote:
3.1.9 beta @ Win XP, map: Ultima Classic

I started the game with 3.1.8 beta but I had up to now no remarkable problems with 3.1.9. Sometimes AI heroes behaved in a strange way (they were going across whole map until the AI process hanged, probably after entering a whirlpool) but it was possible to avoid that after a reload or two.

Now I have a similar situation but the crash is unavoidable - probably because AI heroes have no other way to escape. There is only one AI left, it is down to one town and my very strong secondary hero has landed near the last AI town. The save is
here.

S

Can't confirm this. Tried to load the save, only got error map not available. Can you include the log files?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
stachnie
stachnie


Known Hero
posted June 15, 2011 08:59 PM

Quote:
Can't confirm this. Tried to load the save, only got error map not available. Can you include the log files?


Here you are

S.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 14 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0489 seconds