Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
HOMM1: info forum | HOMM2: info forum | HOMM3: info mods forum | HOMM4: info CTG forum | HOMM5: info mods forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: New Upgrades Mod [Amethyst Edition] for ERA
Thread: New Upgrades Mod [Amethyst Edition] for ERA This thread is 30 pages long: 1 2 3 4 5 ... 10 20 ... 26 27 28 29 30 · «PREV / NEXT»
Akikojam
Akikojam

Tavern Dweller
posted October 01, 2021 06:16 PM

Archer30 said:
Akikojam said:
Archer30 said:


Hi, in order to upgrade the 8th unit, both the 8th dwelling and the 3rd upgrade building needs to be built.


I am aware of that. The problem is that you have those both built and can upgrade. But then at a certain point of time, most likely when you capture another town, you suddenly no longer can upgrade it, even though all conditions are met. In a town where you previously could. Something in the scripts breaks from the look of it, and game no longer realizes that all conditions are met.


Hi, could you please upload your save game for debugging? If possible, please send the save just before encountering the bug. Thank you!


I don't think that's going to help anyone, since you probably won't be able to run it due to mod difference, but here you go
https://mega.nz/file/G49w2ZST#ZuePzukuoCemz2bMxNRF_7GJt9GIoDdoYE6nYZED--0
Two player game, red and green are players. Green has unupgradable coatls.
Mods are: Third Upgrades, XXL, Panda Upgrade (modified so only script that prevents AI dimension door runs), New Interface, Hero Advanced Level Up, Portraits Manager, Dtnmang portraits, Heroines, Big Spell Book, Henchman Mod, 16 2-way teleporters, Resolve Battle, ERA Scripts Eng, WoG Graphics Fix Lite, WoG Scripts, BattleSpeed, Era Erm Framework, WoG. ALl in that order from top to bottom.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
aldzzzv2
aldzzzv2


Hired Hero
posted October 01, 2021 10:19 PM

idk if this is a connected issue but i have a game where i cannot upgrade skeletons in one town, and archers in another. the whole buildings are grayed out even. what's that about?
(as there's hill fort around, it's not a big issue, and those are also low level creatures, but like, were it to happen to top level ones, this issue would potentially become very debilitating indeed.)

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Archer30
Archer30


Adventuring Hero
posted October 01, 2021 11:24 PM
Edited by Archer30 at 23:29, 01 Oct 2021.

Akikojam, thanks for the feedback, it was really heplful to locate the issue.

Here's the fix:
Please open your era root foler/Mods/ResOunD/Data/s and rename 8th creatures in town.erm and 8th creatures in town.ert to -1000 Eighth Monsters.erm and -1000 Eighth Monsters.ert. Then start a new game, and the issue will never happen again

____

aldzzzv2, sounds like you were not playing with random maps, yes?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
aldzzzv2
aldzzzv2


Hired Hero
posted October 02, 2021 12:46 AM

Archer30 said:

aldzzzv2, sounds like you were not playing with random maps, yes?


nope, in fact it's indeed a random map (made with unleashed editor, if that makes any difference).

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Akikojam
Akikojam

Tavern Dweller
posted October 02, 2021 01:42 AM

Archer30 said:
Akikojam, thanks for the feedback, it was really heplful to locate the issue.

Here's the fix:
Please open your era root folder/Mods/ResOunD/Data/s and rename 8th creatures in town.erm and 8th creatures in town.ert to -1000 Eighth Monsters.erm and -1000 Eighth Monsters.ert. Then start a new game, and the issue will never happen again




I did that and haven't encountered that bug yet, but I don't have a second town yet. But I did encounter a different, more minor kind of bug. To test out if it got fixed, I started as a Rampart. Built dryads, which require pegasi as prerequisite, as well as third upgrades. But I couldn't upgrade dryads, I could only hire upgraded ones. Then I noticed that when I mouseover oak dryads on the bottom-left of the town menu, my pegasi icon gets replaced by unupgraded dryads icon. So I built the upgraded pegasi and suddenly could upgrade dryads, and icon was no longer getting replaced. I don't think it was supposed to do that, and I'm not sure if I really needed golden pegasi to upgrade dryads into oak dryads.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Archer30
Archer30


Adventuring Hero
posted October 02, 2021 07:23 AM
Edited by Archer30 at 07:25, 02 Oct 2021.

The upgrade issue was a problem with script orders. By renaming the script, the problem should be fixed. The cancellation of the upgrade chain happens after you visit any hill forts. You can check the difference before and after renaming if you like.

The minor issue of icons in town is not likely to be fixed in the near future. It is a problem with HD mod. We have some "technical issues" contacting the HD author for fixing the compatibility with Third Upgrade Mod, unfortunately.

Akikojam said:
Archer30 said:
Akikojam, thanks for the feedback, it was really heplful to locate the issue.

Here's the fix:
Please open your era root folder/Mods/ResOunD/Data/s and rename 8th creatures in town.erm and 8th creatures in town.ert to -1000 Eighth Monsters.erm and -1000 Eighth Monsters.ert. Then start a new game, and the issue will never happen again




I did that and haven't encountered that bug yet, but I don't have a second town yet. But I did encounter a different, more minor kind of bug. To test out if it got fixed, I started as a Rampart. Built dryads, which require pegasi as prerequisite, as well as third upgrades. But I couldn't upgrade dryads, I could only hire upgraded ones. Then I noticed that when I mouseover oak dryads on the bottom-left of the town menu, my pegasi icon gets replaced by unupgraded dryads icon. So I built the upgraded pegasi and suddenly could upgrade dryads, and icon was no longer getting replaced. I don't think it was supposed to do that, and I'm not sure if I really needed golden pegasi to upgrade dryads into oak dryads.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Archer30
Archer30


Adventuring Hero
posted October 02, 2021 07:27 AM
Edited by Archer30 at 18:08, 02 Oct 2021.

Some options from Era Scripts mod or other mods I suppose? It doesn't sound like part of TUM. Try to disable some mods you have to see if it resolves

aldzzzv2 said:
Archer30 said:

aldzzzv2, sounds like you were not playing with random maps, yes?


nope, in fact it's indeed a random map (made with unleashed editor, if that makes any difference).

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
aldzzzv2
aldzzzv2


Hired Hero
posted October 02, 2021 06:21 PM

Archer30 said:
Some options from Era Scripts mod or other mods I suppose? It doesn't sound like part of TUM. Try to disable some mods you have to see if it resolves



hmm okay. in that case it'll take some time cos i can try this in my next game. i guess it's unlikely for the buildings to become 'active' again deep in the game when disabling something, right?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Archer30
Archer30


Adventuring Hero
posted October 03, 2021 10:42 PM
Edited by Archer30 at 00:44, 04 Oct 2021.

Quote:
it's unlikely for the buildings to become 'active' again deep in the game when disabling something


Never gonna happen. You have to restart a map with new mod settings to test if it works

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Archer30
Archer30


Adventuring Hero
posted October 04, 2021 12:43 AM

Thanks for the report. Will be fixed in the next update.

Benchbreaker said:
Akikojam said:
Archer30 said:


Hi, in order to upgrade the 8th unit, both the 8th dwelling and the 3rd upgrade building needs to be built.


I am aware of that. The problem is that you have those both built and can upgrade. But then at a certain point of time, most likely when you capture another town, you suddenly no longer can upgrade it, even though all conditions are met. In a town where you previously could. Something in the scripts breaks from the look of it, and game no longer realizes that all conditions are met.


I seem to remember encountering something similar, try right click townhall again to make 3rd upgrade work again in a town

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
VMaiko
VMaiko


Known Hero
posted October 11, 2021 06:15 AM
Edited by VMaiko at 00:18, 15 Oct 2021.

New update

Update v2.13.0

Changelog

-Now TUM is compatible with RoE/AB maps and campaigns.
-Added high-quality PNG portraits to SoD's artifacts and creatures and some new of the mod that needed fixing.
-Fixed graphic of Acid Wyvern in adv map.
-Amethyst's necromancy was superseded by one written in ERM by PerryR.
-The appearance of Sacred Phoenix, Divine Phoenix, Lord of Thunder and Guardian of Zeus were replaced.
-Necross Dragon has been returned as a reward at Rotten Dragons Valley CB.
-Several changes in the scripts, for example, the dependency on Emerald Tower and Wogify.erm was removed.
-TUM options have been moved to the first page of WoG option menu.
-Now you are able to recruit all 3rd upgraded monster by clicking buttons from the left bottom of town screen.
-Fixed the thumbnail of the left bottom of town screen changed unexpectedly when upgrading new creatures.
-Necro heroes will now transform some of their living monsters to their skeleton counterparts upon visiting skeleton transformer (both in town and map objects).
-Fixed skeleton transformer dialogue pop-ups when AI visits skeleton transformer.
-Fixed occasional experience anomalies.
-Fixed an erm error of Lightning Rod.
-Fixed occasionally not able to upgrade 8th monster in town.
-Fixed occasionally the 3rd upgrade recruit dialogue doesn't appear even if the third upgrade building is built.
-Fixed some behaviours of demolishing buildings.
-The corresponding credits have been modified.

Update V2.13.1

Changelog

-Removed intrusive zpic1005.bmp in the mod.
-Fixed skeleton transformer crashes and bugs.
-Fixed a bug in which Castle Units were recruited from other factions.
-Fixed the problem of some TUM combos artifacts, which could not be assembled and disassembled.

--------------------------------------------------------------

A Github has been opened in the main thread, anyone who wants to collaborate with the mod is welcome.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
aldzzzv2
aldzzzv2


Hired Hero
posted October 22, 2021 12:14 AM

been having serious issues with not being able to load any maps, neither custom nor random (plz see launcher thread).

limited it down having this issue with latest version of tum installed/enabled.

Quote:

[HOMM3 HD CRASH LOG]

Log
{
compability_dir = C:GamesHoMM 3 ERA_HD3_DataCompability#era
EXE_VERSION & TE
EXE_VERSION & ERA

}

HOMM3 HD version: 5.2 R74
Time {   10/22/2021 01:11:09 }

GUN:  [HM797491093460TRTZYBGV TK-THGUH68899GMGW]

Exception
{
  Module: KERNELBASE.dll
  Adress:      [ KERNELBASE.dll+0x12B5B2 ]
  Code:        0x0EEDFADE
  Flags:       EXCEPTION_NONCONTINUABLE
  Information: 0x05894EA1 0x065AC050 0x05894EA1 0x05894EA1 0x1017F7FA 0x02D36624 0x02D365EC
}

Context { EAX: 0x02D36560, ECX: 0x00000007, EDX: 0x00000000, EBX: 0x05894EA1, ESP: 0x02D36560, EBP: 0x02D365B8, ESI: 0x05894EA1, EDI: 0x1017F7FA }

Call stack
{
  ? called from before [ 0x00000001 ]
  ? called from before [ 0x00000000 ]
}



should i downgrade or? thanks!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
viden
viden

Tavern Dweller
posted October 30, 2021 08:07 PM

aldzzzv2 said:
been having serious issues with not being able to load any maps, neither custom nor random (plz see launcher thread).


I fixed this problem by disabling WoG script "Enhanced Monsters", maybe it will work for you too. This is a picture of my settings:


____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
aldzzzv2
aldzzzv2


Hired Hero
posted October 30, 2021 10:23 PM

viden said:
aldzzzv2 said:
been having serious issues with not being able to load any maps, neither custom nor random (plz see launcher thread).


I fixed this problem by disabling WoG script "Enhanced Monsters", maybe it will work for you too. This is a picture of my settings:




interesting!
thanks for bringing this up, will try it out as soon as i finish my latest map. (been playing with an older version of amethyst via kind help from discord. )

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
lesiak
lesiak

Tavern Dweller
posted October 30, 2021 10:53 PM

viden said:
aldzzzv2 said:
been having serious issues with not being able to load any maps, neither custom nor random (plz see launcher thread).


I fixed this problem by disabling WoG script "Enhanced Monsters", maybe it will work for you too. This is a picture of my settings:




Thanks! for me its working

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
bloodshade21
bloodshade21

Tavern Dweller
posted November 09, 2021 09:43 PM

Hello guys,

I haven't played this mod since ERA 2, so now I decided to try it again. I absolutely love the graphics, quality of life improvements (such as the tooltip at the bottom of the town screen which shows how much does the upgrade cost), and the new content. However, I'm not really satisfied with the random map generator, so I have a couple of questions:

1. Although there are some really cool neutral creatures in the game now, I've got to say that there are others that are kind of bland and mediocre. So, the question for the mod creators is, how can I disable the replacements for some of the new creature dwellings? I tried to create a new folder inside the 's' file and put the replacement scripts for the objects I didn't want to include in that new folder, but it didn't work. They still come up in the randomly generated maps. Another side note, those new creature banks where you get lvl 8 units (there is one for each faction) are really cool but are way too randomly placed on the map. It doesn't make much sense that there are 2 Olympus Forgotten objects in my starting area (which is often quite small and limited in the RMGs), especially if I'm playing Stronghold.

2. For everyone who plays this mod: Which maps or templates do you play this mod on? Personally, I haven't found any of the given templates for the RMG satisfying (probably the best one is Jebus Cross). Have you by any chance created a cool custom map that is well-suited for this mod, and would like to share?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
VMaiko
VMaiko


Known Hero
posted December 09, 2021 12:08 AM

Version 2.13.3 has been released and with it the official guide of the mod made 100% by me, this is the first version of the manual (v1.0) that is also included in the root folder of the mod, there would still be missing information to add, so the information may change and be expanded later.

Changelog
-Fixed a bug where Beholders' Sanctuary gave Angels as reward.
-Fixed some artifact names and descriptions.
-Fixed the cost of some combo artifacts.
-Fixed an artifact that could not appear on the map.
-Fixed problem of generation of some dwellings in custom map.
-Fixed Dragon City CB overgeneration issue.
-Improved the creature bank "Ruins".
-Added 1 new creature.
-Added 1 new artifact.
-Slith Pool dwelling is now animated.

Features of the manual
-Basic information on how to install Third Upgrades Mod.
-Basic information on how the mod works.
-Main information of creatures, artifacts and creature banks.
-Guide on how to create a creature in the mod.
-Guide on how to create an artifact in the mod.

Third Upgrade Mod Manual

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Quique30
Quique30


Adventuring Hero
posted December 15, 2021 12:56 PM

Thank you so much for the update and manual!

Like I said before, mod is very stable and enjoyable. Only issue I'm experiencing is the one I described related to the new Colosseum of Magic:

http://heroescommunity.com/viewthread.php3?TID=46241&PID=1553056#focus

Have you guys have been able to reproduce it? It's rather bad because, often, AI's best heroes get trapped in it.

Cheers!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
TumT
TumT

Tavern Dweller
posted January 09, 2022 05:35 AM

Running into consistent crashes after loading the Third Upgrade mod. Everything is up to date, with the following in use:

Third Upgrade, ACM, Legend Menu English Version, XXL-mod, TrainerX, 10SSkills, ERA scripts Eng, Secondary Skills Scorlling, WoG Graphics Fix LIte, Game Enhc. Mod, BattleSpeed, QuickSaving, Spells Descp., Unleashed Edit., WoG Scripts, Battle Queue, ERA ERM Framework, WoG Core.

The down and dirty is anytime I go into combat w/ a computer (or any hero, I guess), I'll run into a popup w/ :"ResourceManger::GetSample could not find the "sfx" resource "xxxyyy.82m"." where xxxyyy is a catapult, first aid tent or ballista sfx file for attack, defense and retreat (cataattk.82m, faiddfnd.82m, etc etc). During a hero battle I'll get these popups w/o issue; but going into a siege, I'll get the 9 popups, the tower archer's will attack and the fight screen will be removed to the world map and the game will crash. My debug folder, crash log and save game are located here

https://drive.google.com/drive/folders/1LnK2QhV01KSqGGCLdq-p98fvsbWJeCbz?usp=sharing

and the top snippit of my crash log is below

Log
{
compability_dir = C:GamesHomm 3 ERA_HD3_DataCompability#era
EXE_VERSION & TE
EXE_VERSION & ERA

}

HOMM3 HD version: 5.2 R84
Time {   01/08/2022 18:02:43 }

GUN:  [H78MMCZTZ20090QHZNHFMT HHW 149 VEL 749TY]

Exception
{
  Module: h3era hd.exe
  Adress:      [ 0x004676EE ]
  Code:        EXCEPTION_ACCESS_VIOLATION
  Flags:       0x00000000
  Information: read of address: 0x00000030
}

Following my wife's method, a quick combat will prevent the error since it doesn't need to animate the fight, so there's no real rush, I guess. Thanks for any insight you guys might have.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
AnnihilatorX18
AnnihilatorX18

Tavern Dweller
posted January 09, 2022 08:22 AM

Resurrection spell doesn't work on Spectral Behemoths. Is it possible to replenish their numbers?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 30 pages long: 1 2 3 4 5 ... 10 20 ... 26 27 28 29 30 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0895 seconds