Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 6 - The New Beginning > Thread: ~ Heroes 6 patch 2.1 - Bug reports ~
Thread: ~ Heroes 6 patch 2.1 - Bug reports ~ This thread is 12 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 · «PREV / NEXT»
Hermes
Hermes


Famous Hero
posted June 20, 2013 03:38 PM

Naki, umm yes they certainly are! They have correct abilities now.

Anyway I foujd a bug.

Got to say that it was spotted while playing duel with someone who used 2.1.0 and I have 2.1.1.

The bug is(happened twice).  Cast Feign Death on Scorpicores(could work on other troops as well), then order it to attack or use its ability on any enemy stack. Now, if you scorpicore gets damaged before commencing the attack(agony, earth and sky effect, centaurs area of control ability) - death animation plays but the battle freezes and only thing that works is exiting to main menu.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Naki
Naki


Known Hero
posted June 20, 2013 03:52 PM
Edited by Naki at 16:04, 20 Jun 2013.

Quote:
You may be right that this particular bug wasn't introduced now, but there are other examples that show patches introducing bugs. In my case, black screen issue is such a bug. It never occured on my computer before 2.1 patch, and since 2.1 appeared, I got black screens along with it.

It seems there are at least TWO such Black Screen bugs (maybe 3+?). And one of them has been there forever, NOT since patch 2.1 by any means.
Anyway, which Black Screen bug do you experience?
Black Screen on trying to attack neutrals/enemy town/fort, with music playing? If so, that is an old bug, and ~should~ be easily worked around by closing all browsers/browser tabs, especially ones playing online video and/or Flash ads, plus closing any other games or GPU-using apps. Which suits me just fine, but may be annoying to some.

If not, which is it?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
frostymuaddib
frostymuaddib


Supreme Hero
By the power of Vivendi!
posted June 21, 2013 10:48 AM

Quote:
Black Screen on trying to attack neutrals/enemy town/fort, with music playing? If so, that is an old bug, and ~should~ be easily worked around by closing all browsers/browser tabs, especially ones playing online video and/or Flash ads, plus closing any other games or GPU-using apps. Which suits me just fine, but may be annoying to some.


That's the one. It never happened to me with older versions, started only with 2.1. Anyway, I tried all of the workarounds I could find on forums, including the one you mentioned, and that didn't help. The only thing that made the bug very rare is running the game in safe mode, but they removed that option from uplay. When I play, and it is very rare, I just save like crazy, so I can easily continue when everything goes black.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Naki
Naki


Known Hero
posted June 21, 2013 11:22 AM
Edited by Naki at 11:29, 21 Jun 2013.

What videocard do you use? What OS?
My solution worked fine for me, and I think the problem was there always, or at least since 1.5.x patches.

My OS is Windows 7 64-bit Ultimate SP1, and videocard is Nvidia GeForce GTX 670.

I am curious - do you get the Black Screen only on trying to attack something, or does it happen at other times too?

Did you contact UBI support? If not, maybe you can do that - they maybe won't help much, but it a good idea to do it anyway.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
frostymuaddib
frostymuaddib


Supreme Hero
By the power of Vivendi!
posted June 21, 2013 12:32 PM

I have Win7 home premium SP1, nvidia GeForce GT 525M (with integrated Intel graphics, it's on laptop). Already contacted support, sent them dxdiag an waiting for further instructions . Black screen appears in two cases, when battle starts and when I enter town for the first time (when there is Loading screen). I know that there were issues with nvidia graphics and laptops earlier and one of the suggestions was to downgrade graphic drivers, but that is the only thing that I haven't tried and won't, HoMM6 is not worth that much

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Locksley
Locksley


Promising
Famous Hero
Wielding a six-string
posted August 13, 2013 07:58 PM

It's impossible to play Dungeon in offline mode.


Normally, in online mode you can select a might or magic hero from each faction for your AI opponent.

Here's the list of names:
Yugen, Hitomi, Zenda, Sir Jaywoods, Karloff, Eileen, Malik, Lamia, Mokka, Matewa.
- Kastore and Lorelei are the Dungeon heroes.


When offline you can choose among the same heroes for your AI opponent and yourself
- but Kastore and Lorelei are not in the list.


So there's no Dungeon when offline.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Elvin
Elvin


Admirable
Omnipresent Hero
Tastes like chicken
posted August 13, 2013 09:48 PM

From what I've heard, you need to delete "DynastyData.bin" in "\My Documents\Might & Magic Heroes VI\Username\" first.
____________
Being human is a roller coaster ride of emotions during rainstorms and sunshine, sprinkled with moments when you can almost reach the stars.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Locksley
Locksley


Promising
Famous Hero
Wielding a six-string
posted August 14, 2013 04:52 PM

Thank you, it worked!

However, I only tested to move the DynastyData.bin to my desktop. I didn't dare to delete the file because I thought deleting the file harm my dynasty somehow. Is it harmful?
After the test when I were going to put the DynastyData.bin back in its folder, a new DynastyData.bin file had already been recreated but I don't know if the two versions have the same content. Weird.
I suppose I shouldn't worry too much about it.


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
vicheron
vicheron


Known Hero
posted August 17, 2013 11:16 AM

It seems that a recent Windows Update has made it impossible to launch the game.

I have Windows 7 and after restarting my computer after a Windows Update, the game and gu.exe won't launch at all. When I try to start it, the autopatch window opens up, closes, and then nothing else happens. I can open up Uplay with my other Ubisoft games but I can't launch Heroes 6 from Uplay. I click on the play button, the autopatch window opens, closes, the play button is unclickable for a few seconds, and nothing else happens. If I click the play button again, the same thing happens again. Is anyone else having this problem?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Naki
Naki


Known Hero
posted August 17, 2013 11:16 AM

Two new bugs I encountered:
1) Intro movie shows only bottom part, TOP part is black/blank.
Support says this may be related to Windows Update update with number KB2803821 (Windows Vista, 7, and 8) and KB2834904 (for Windows XP).
I uninstalled it, which did not fix the issue. Then however, after 1-2 days, I installed the update again, and the half-screen issue seems solved.

2) UBI Launcher crashes, can't run game. Restarting the PC fixes this for a while, then after a certain event and/or few hours, the crashes start again. Then an update for the UBI Launcher came out, which may have fixed this crash.

It seems both bugs are fixed now, but I can't say for sure, because I don't have the time to play the game now.
(And in fact have not played in the last 2-3 months.)

Have any of your encountered the above bugs? Are they still there, or does it work fine now?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
frostymuaddib
frostymuaddib


Supreme Hero
By the power of Vivendi!
posted August 17, 2013 03:27 PM

After reading latest posts, I tried to run my Heroes 6 after long time. Uplay updated and now game always crashes when I start it.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Naki
Naki


Known Hero
posted August 17, 2013 04:26 PM
Edited by Naki at 15:35, 19 Aug 2013.

frostymuaddib said:
After reading latest posts, I tried to run my Heroes 6 after long time. Uplay updated and now game always crashes when I start it.

Please a screenshot of crashed window!?
Please also screenshot or text of Details/More info, if one is available.

My text was this:
Problem signature: Problem Event Name: BEX Application Name: UbisoftGameLauncher.exe Application Version: 0.0.0.0 Application Timestamp: 51cdb7e2 Fault Module Name: UbisoftGameLauncher.exe Fault Module Version: 0.0.0.0 Fault Module Timestamp: 51cdb7e2 Exception Offset: 000c5d53 Exception Code: c0000417 Exception Data: 00000000 OS Version: 6.1.7601.2.1.0.256.1 Locale ID: 1026 Additional Information 1: 278b Additional Information 2: 278b11c9965bf0784fb38343e2a2c902 Additional Information 3: f68b Additional Information 4: f68b48a948f31df38a8081b94ccd2df3

I am using Windows 7 64-bit, Ultimate, SP1. Heroes VI 2.1.1 vanilla, no expansions, Russian version. Intel Core i7 CPU, 32 GB RAM, GeForce GTX 670 videocard.
However, after some UPlay updates, it seems I don't get above crash any more and game works fine. But I REALLY can't play anyway, since I am overburdened with work and other IRL stuff.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
frostymuaddib
frostymuaddib


Supreme Hero
By the power of Vivendi!
posted August 19, 2013 10:25 AM

Now, I cannot reproduce the crash window, because when I start the game from Uplay, it runs autopatcher and nothing happends Things are getting better and better. Time to uninstall this disgraceful game...

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Thanatoeil
Thanatoeil


Adventuring Hero
posted August 19, 2013 05:01 PM
Edited by Thanatoeil at 17:02, 19 Aug 2013.

Naki said:
1) Intro movie shows only bottom part, TOP part is black/blank.

I confirm this bug : it appeared on my computer after a Microsoft Windows update. I never made any uninstall to remove this bug.
And last week, after a new Microsoft Windows update, the bug disappeared.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Naki
Naki


Known Hero
posted August 20, 2013 11:50 AM

Thanatoeil said:
Naki said:
1) Intro movie shows only bottom part, TOP part is black/blank.

I confirm this bug : it appeared on my computer after a Microsoft Windows update. I never made any uninstall to remove this bug.
And last week, after a new Microsoft Windows update, the bug disappeared.

Thanks for confirming!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Thanatoeil
Thanatoeil


Adventuring Hero
posted August 22, 2013 02:45 PM

Bugs about visibility radius (Scouting)

I made some tests on the mechanism of visibility (game version : 2.1.1). Two parameters can be checked :
- hero's visibility radius (HVR) (Scouting radius) : how far a hero can identify objects on the map (object showing tooltip)
- player's visibility radius (PVR) : what part of the map the player can see on his screen (unveiled fog of war)

Basic hero :
northward : HVR=12 tiles / PVR=12 tiles (the last tile is 50% visible)
westward : HVR=12 / PVR=13 (50%)
southward : HVR=12 / PVR=13 (50%)
eastward : HVR=11 / PVR=11 (100%)

Hero with Scouting I : add 1 to all the values
Hero with Scouting II : add 2 to all the values
Hero with Scouting III : add 3 to all the values

Artifacts giving Scouting bonus : the bonus doesn't work (radius unchanged) (the artifacts were tested on hero with and without Scouting skills).

That's another poorly developped part of HeroesVI, and I don't think visibility radius is a very complicated thing.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
The_Polyglot
The_Polyglot


Promising
Supreme Hero
zombie
posted August 22, 2013 04:57 PM

Did You wait for a turn for the arties to become active?
____________
You're someone else's problem
Now I only want you gone...
-Glados

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Thanatoeil
Thanatoeil


Adventuring Hero
posted August 22, 2013 06:48 PM

The_Polyglot said:
Did You wait for a turn for the arties to become active?

The first tme, I didn't wait for a turn.
But I just retested it : waiting a turn doesn't change anything, the artifacts with scouting bonus are bugged.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
natalka
natalka


Supreme Hero
Bad-mannered
posted August 22, 2013 08:04 PM

what turn to wait? In h6 +movement arties work right away!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Araedros
Araedros

Tavern Dweller
posted September 28, 2013 10:50 AM

new player here.
I've just started playing M&MH 6 and only patched up to 1.8 for now.
Two things I've noticed are the following:
A bug on the Seraphs/Celestials upgrade where the sword of Mercy/Epiphany is in the wrong version of the unit.

A bug with Guardian Angel ability where instead of making you invincible for one turn it actually makes you invivncible until your stack attacks another stack. Afterwards this stack can be targetted casually.

I don't know if these issues have been fixed in 2.1 patch, just putting them out there so other users can consider them

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 12 pages long: 1 2 3 4 5 6 7 8 9 10 11 12 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.0333 seconds