Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: Era II
Thread: Era II This Popular Thread is 168 pages long: 1 20 40 60 80 100 120 140 ... 158 159 160 161 162 ... 168 · «PREV / NEXT»
xericsin
xericsin


Known Hero
posted March 08, 2018 11:11 AM

@Bersy

Can we have a New Trigger that triggers whenever a stack move to a new hex or leave an old hex in the battlefield?

This shall be very fun.

Like Master of Puppets has monster attacking passing-by enemies.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted March 08, 2018 05:45 PM

Help Please

my mod stopped to save new games about week ago, and I cannot fix it

here is my mod's git archive

I send A crash report before, but it's repetitive so you can reproduce it again.

it's reproducible on both era 2.74 and era 2.65 (sorry for my previous false reports about 2.74 - it's probably not it's fault).

to reproduce: use only wog and my mod, load advertised settings, start new game pass through dialogs, then try to save (both "s" and saving from menu generates same bug). then game crashes with "hd crash log". (mod needs HD-Mod for one of plugins anyway)

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
blackstomper
blackstomper


Adventuring Hero
Member of the old Wog-team
posted March 08, 2018 06:03 PM

How do I activate the startup video again?
Made a clean install and just realised that it is missing

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted March 08, 2018 06:21 PM

blackstomper said:
How do I activate the startup video again?
Made a clean install and just realised that it is missing


Quote:
Show Intro=1

in heroes3.ini

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
blackstomper
blackstomper


Adventuring Hero
Member of the old Wog-team
posted March 08, 2018 06:30 PM

majaczek said:
blackstomper said:
How do I activate the startup video again?
Made a clean install and just realised that it is missing


Quote:
Show Intro=1

in heroes3.ini


Thanks!!!!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
zin33
zin33

Tavern Dweller
posted March 10, 2018 05:25 PM
Edited by zin33 at 18:34, 10 Mar 2018.

hello so i just installed Era 2.7 and ive noticed the game runs kinda laggy. even the main menu feels choppy when moving the mouse around. in game sometimes when moving my hero around i even get a whole second where everything is frozen. turns of the AI on maps where they cant do anything and were normally instant now take a bit of time as well.
tried compatibility mode with xp sp3 but nothing. any ideas?

edit: well with the hd mod i kind of fixed it. the map still lags but i think its the map thats a bit laggy (journey of my life)
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
majaczek
majaczek


Supreme Hero
Work at Magic Dimmension
posted March 11, 2018 05:31 PM

majaczek said:
Help Please

my mod stopped to save new games about week ago, and I cannot fix it

here is my mod's git archive

I send A crash report before, but it's repetitive so you can reproduce it again.

it's reproducible on both era 2.74 and era 2.65 (sorry for my previous false reports about 2.74 - it's probably not it's fault).

to reproduce: use only wog and my mod, load advertised settings, start new game pass through dialogs, then try to save (both "s" and saving from menu generates same bug). then game crashes with "hd crash log". (mod needs HD-Mod for one of plugins anyway)


I Fixed it!!! the guilty was the corrupted settings file
it came from new mod manager editing settings file
I set the options manually in game from zero and it works.

PS: there is still a problem between lua and HD mod. currently I disabled lua scripts on my copy and it works :F

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Bersy
Bersy


Honorable
Supreme Hero
posted March 15, 2018 08:55 PM

Quote:
Can we have a New Trigger that triggers whenever a stack move to a new hex or leave an old hex in the battlefield?

I'm currently working on lua scripts. I think such triggers should be implemented by lug plugin makers in the future without a need to recompile era library.

majaczek, I'm really sorry, have very limited time for debugging now.

Quote:
hello so i just installed Era 2.7 and ive noticed the game runs kinda laggy. even the main menu feels choppy when moving the mouse around. in game sometimes when moving my hero around i even get a whole second where everything is frozen. turns of the AI on maps where they cant do anything and were normally instant now take a bit of time as well.
tried compatibility mode with xp sp3 but nothing. any ideas?

edit: well with the hd mod i kind of fixed it. the map still lags but i think its the map thats a bit laggy (journey of my life)

Edit heroes3.ini, set CpuPatch = 0.
____________
Heroes 3 Era and everything for it. Releases folder for releases.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
rusual3x10
rusual3x10

Tavern Dweller
posted March 17, 2018 12:00 AM

animations and crash bugs

Hello ,during my gameplay i have encountered the fact that when i move my mouse everything stops animatin(for example creatures stop moving).The other issue is that my game crashes during opponent s turn around month 4-6,me using only a few mods(new upgrades,upgrade all,fix overflow ).Do you know how i could fix these?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
atmos55
atmos55

Tavern Dweller
posted March 23, 2018 04:50 AM

Hi,

I really like the mod Conquistador by Salamander, but it has a bug in ERA, where every enemy creature gets ACE levels of experience, even when the option ACE is unchecked.

I even tried editing the ERM and taking out all reference to ace function... but still, can't get it to work.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted March 24, 2018 01:51 PM
Edited by Salamandre at 13:54, 24 Mar 2018.

rusual3x10 said:
Hello ,during my gameplay i have encountered the fact that when i move my mouse everything stops animatin(for example creatures stop moving).The other issue is that my game crashes during opponent s turn around month 4-6,me using only a few mods(new upgrades,upgrade all,fix overflow ).Do you know how i could fix these?


Is normal that when you hover mouse over creatures, they stop their actual animation. For your game crash, is mostly a map problem, upload a save and I'll look.

atmos55 said:
Hi,

I really like the mod Conquistador by Salamander, but it has a bug in ERA, where every enemy creature gets ACE levels of experience, even when the option ACE is unchecked.


The option "gets ACE" is ensuring that AI will ALWAYS have ACE, even if attacked first day. If you deselect it, it will still get ACE if it fought enough and deserves it by normal means. It works exactly as the option "AI always has full mana": even if unchecked, AI will still have full mana if it visits a well, right? If you want no experience at all, uncheck the wog option "troops stack experience".

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
atmos55
atmos55

Tavern Dweller
posted March 24, 2018 08:40 PM
Edited by atmos55 at 20:42, 24 Mar 2018.

Salamandre said:


If you want no experience at all, uncheck the wog option "troops stack experience".


Well, I want troop stack experience only for the player, not for the AI. I want to disable it for the AI. So normally it works if I set the WOG option AI stack experience to NONE (in the stack experience settings in WOG Options), and only the player gets stack experience. But if I install the conquistador mod, it doesn't work, the AI gets stack experience. I don't understand why, because I went through your ERM script and deleted all reference to ace.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted March 24, 2018 08:54 PM
Edited by Salamandre at 20:56, 24 Mar 2018.

To disable all experience scripts you just need to change this line:

!!DO418890/0/40/1&y2>0:P;

to

!*DO418890/0/40/1&y2>0:P;

Thats all, do not remove anything else or mod will certainly screw.


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
atmos55
atmos55

Tavern Dweller
posted March 24, 2018 10:07 PM

hmm, doesn't work, still all AI enemy troops are ACE level of experience . I used the ERM editor to make the changes.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted March 24, 2018 10:22 PM
Edited by Salamandre at 22:23, 24 Mar 2018.

Have you checked if without conquistador it still has same? Because my mod does not change that at all.

Also, if you made the erm changes then reload a save, did you press F12? Without that, nothing will change, F12 reloads the new erm configuration.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
atmos55
atmos55

Tavern Dweller
posted March 24, 2018 10:36 PM
Edited by atmos55 at 22:37, 24 Mar 2018.

Yes, it works without Conquistador, on Era 2 basic installation, without a save game. It's only a problem when I install conquistador.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Salamandre
Salamandre


Admirable
Omnipresent Hero
Wog refugee
posted March 24, 2018 10:44 PM
Edited by Salamandre at 22:45, 24 Mar 2018.

Check for this line then disable it (!*):

!!DO150899/0/6/1:Px16; set AI army to rank 10 every day

However, to work it will need new game, will not work with saved because obviously it already set AI army to Ace.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
atmos55
atmos55

Tavern Dweller
posted March 24, 2018 10:52 PM

That works! Thanks! Your mod is great btw.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
alexcmartin1
alexcmartin1

Tavern Dweller
posted March 25, 2018 06:16 PM

Grove town

Hello,

I recently downloaded Era II, the grove town mod and WOG plus. I unpacked all into my Heroes 3 complete folder. I am able to start games with the new Grove town and the town itself functions perfectly. However, all of my battle screens are just a black background and the animation is messed up. What can I do to fix this? Thanks for your help.


____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
avatar
avatar


Promising
Famous Hero
posted March 25, 2018 06:51 PM

Download recent ERA version 2.7.4.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This Popular Thread is 168 pages long: 1 20 40 60 80 100 120 140 ... 158 159 160 161 162 ... 168 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.1355 seconds