Heroes of Might and Magic Community
visiting hero! Register | Today's Posts | Games | Search! | FAQ/Rules | AvatarList | MemberList | Profile


Age of Heroes Headlines:  
5 Oct 2016: Heroes VII development comes to an end.. - read more
6 Aug 2016: Troubled Heroes VII Expansion Release - read more
26 Apr 2016: Heroes VII XPack - Trial by Fire - Coming out in June! - read more
17 Apr 2016: Global Alternative Creatures MOD for H7 after 1.8 Patch! - read more
7 Mar 2016: Romero launches a Piano Sonata Album Kickstarter! - read more
19 Feb 2016: Heroes 5.5 RC6, Heroes VII patch 1.7 are out! - read more
13 Jan 2016: Horn of the Abyss 1.4 Available for Download! - read more
17 Dec 2015: Heroes 5.5 update, 1.6 out for H7 - read more
23 Nov 2015: H7 1.4 & 1.5 patches Released - read more
31 Oct 2015: First H7 patches are out, End of DoC development - read more
5 Oct 2016: Heroes VII development comes to an end.. - read more
[X] Remove Ads
LOGIN:     Username:     Password:         [ Register ]
New Server | HOMM1: info forum | HOMM2: info forum | HOMM3: info forum | HOMM4: info forum | HOMM5: info forum | MMH6: wiki forum | MMH7: wiki forum
Heroes Community > Heroes 3.5 - WoG and Beyond > Thread: Official VCMI Thread
Thread: Official VCMI Thread This thread is 97 pages long: 1 2 3 4 5 ... 20 40 60 80 ... 93 94 95 96 97 · «PREV / NEXT»
erra_zx
erra_zx

Tavern Dweller
posted March 31, 2018 02:36 AM
Edited by erra_zx at 13:57, 01 Apr 2018.

dear all,

my first ever post here so I'm very sorry if I'm writing this in the wrong thread.

installed heroes iii complete, unpacked the vcmi zip, copied data, maps and mp3 folders into vcmi unzipped folder. in the vcmi_launcher, I enable factory, wog, mods for monsters, etc.

game opens good, I can choose a scenario and start playing. two things, however.

while in the castle and left-clicking on some stack, no window will open
with information but text bleeds into town's background image. I can remove this by hitting esc.

and second, worst, thing. I can buy stacks, start moving around the map but the moment I'm getting into a fight with a neutral stack, vcmi crashes. "Program has stopped working."

I'm on win7, x32. also new to playing modded hommm so I'm sorry if my description sounded too stupid.



with best,

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
erra_zx
erra_zx

Tavern Dweller
posted April 01, 2018 03:20 AM

more info. what might be wrong pls?


 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
just0
just0


Adventuring Hero
posted April 01, 2018 03:48 AM
Edited by just0 at 03:49, 01 Apr 2018.

erra_zx said:
installed heroes iv complete
Maybe you should try installing Heroes III Complete instead.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fred79
fred79


Promising
Undefeatable Hero
there's gonna be hell toupee!
posted April 01, 2018 04:15 AM

oh, no way, lol.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Warmonger
Warmonger


Promising
Legendary Hero
fallen artist
posted April 01, 2018 06:53 AM

Some VCMI files are missing - incorect installation. Start over and don't enable any mods before you figure out it works.
____________
The future of Heroes 3 is here!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
avatar
avatar


Promising
Famous Hero
posted April 01, 2018 09:25 AM
Edited by avatar at 09:28, 01 Apr 2018.

You must also dowload vcmi essential files and copy them to your h3/vcmi folder. Besides you must download and install latest daily builds from here https://builds.vcmi.download/branch/develop/Windows/ because some mods are incompatible with old 0.99 zip package.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
erra_zx
erra_zx

Tavern Dweller
posted April 01, 2018 02:00 PM

typoed, meant heroes iii obvs.

I just tried reinstalling etc yesterday.

when I open the launcher the first time, it shows essential files as in need for an update, so I let it update and then enable.

then I'm enabling factory and starting the game.

yet, before the fight with a neutral stack can begin, I get the error I screencaped above.

anyways, going to try with nightly build and also with manual installation of essential files. hoping it will work.

thanks for the suggestions!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
just0
just0


Adventuring Hero
posted April 01, 2018 02:17 PM

erra_zx said:
meant heroes iii obvs.
You never know. Internet people can be a strange lot.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Warmonger
Warmonger


Promising
Legendary Hero
fallen artist
posted April 01, 2018 02:30 PM

Quote:
when I open the launcher the first time, it shows essential files as in need for an update, so I let it update and then enable.

Well, you shouldn't do that.
____________
The future of Heroes 3 is here!

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
erra_zx
erra_zx

Tavern Dweller
posted April 01, 2018 03:01 PM
Edited by erra_zx at 03:02, 02 Apr 2018.

ok so, some updates.

I *think* I got it to work but it's still not 100% there.

1. installed homm iii complete (c:gog games...)
2. as per https://wiki.vcmi.eu/Installation_on_Windows, copied data, maps and mp3 folders from gog games to my games\vcmi (altho I had to manually create "vcmi" folder (this is said nowhere in the tutorials and help materials)
3. unpacked vcmi essentials (downloaded from https://wiki.vcmi.eu/Mod_list) and copied the unzipped content to my games\vcmi
4. unpacked factory, copied the contents to my games\vcmi\mods
5. opened launcher, enabled everything under essentials + factory
6. changed screen rez to 1920x1080, intro off, battleAI
7. opened vcmi_client

battles work now, no crash. however, I seemingly cannot play in max rez, it still opens at 800x600. even tho extraResolutions mod is present in the mods folder and it's also set to max in the launcher, as noted. it's a minor thing but before, when it crashed on battle initiation, max rez worked, though. so idk what's wrong with it now.

either way, resolution issue notwithstanding, I guess now it's safe to copy over all the other mods I want, following the same procedure as outlined above, right?

thanks for the replies btw, really appreciated. hate being n00b at stuff, lol.



 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RandomName
RandomName

Tavern Dweller
posted April 01, 2018 04:29 PM

erra_zx said:
ok so, some updates.

battles work now, no crash. however, I seemingly cannot play in max rez, it still opens at 800x600. even tho extraResolutions mod is present in the mods folder and it's also set to max in the launcher, as noted. it's a minor thing but before, when it crashed on battle initiation, max rez worked, though. so idk what's wrong with it now.




check if you have more than one file "resolutions.json" somewhere in mygames/vcmi or in vcmi installation path

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
erra_zx
erra_zx

Tavern Dweller
posted April 01, 2018 04:38 PM
Edited by erra_zx at 16:39, 01 Apr 2018.

thanks for this!

apparently I do.

here's one in: My Games\vcmi\Mods

and another is in: My Games\vcmi\Mods\vcmi\Mods

which should I delete?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
avatar
avatar


Promising
Famous Hero
posted April 01, 2018 04:54 PM
Edited by avatar at 16:56, 01 Apr 2018.

None. Some mods have submods. My games/vcmi/Mods is the main mods folder where you must copy all mods. The second one contains submods of vcmi essential files mod.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
avatar
avatar


Promising
Famous Hero
posted April 01, 2018 05:01 PM

Sometimes you can get duplicate folders (minor bug in 0.99 package). So if you find duplicate 'extraResolution' folders in any Mods directory with the same content, delete folder which is 'deeper'.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
erra_zx
erra_zx

Tavern Dweller
posted April 01, 2018 05:17 PM

well, now I deleted the one in the \My Games\vcmi\Mods\vcmi\Mods

but it's still 800x600.

also getting this in the cmd window:



what is going wrong still?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
avatar
avatar


Promising
Famous Hero
posted April 01, 2018 06:00 PM

Just try this.
Delete all 'Mods/vcmi...' from My games/vcmi and also from gamesvcmi folder. Unpack vcmi essential files once again and copy folder Mods to gamesvcmi folder.
About red video warning - it's minor error, games seeks video from h3 cd drive ot sth. It doesn't affect the game.
____________

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
RandomName
RandomName

Tavern Dweller
posted April 01, 2018 10:30 PM

For me the one deeper was ok, you should delete that what which is smaller xD

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
fred79
fred79


Promising
Undefeatable Hero
there's gonna be hell toupee!
posted April 02, 2018 09:17 AM

erra_zx said:
typoed, meant heroes iii obvs.


damn. i thought somebody had made an original(and amusing) mistake.

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
erra_zx
erra_zx

Tavern Dweller
posted April 02, 2018 03:15 PM

well, sadly I'm back to square one here.

became too hasty with adding all these great mods to the point of client not even 'booting up'.

so I deleted the content of the my games\vcmi folder & followed the steps I outlined a few posts up. however, now I cannot even understand how these steps could've worked cos I'm not copying over vcmi 0.99 unzipped files at all there.

so I tried it with those steps + copied over the files/folders nevertheless.

but same problem of game not even starting up remains.

not sure at all what I'm doing wrong constantly, quite distressing. :/

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
planetavril
planetavril


Adventuring Hero
posted April 04, 2018 12:10 PM

I would like to add an object that clicking on it makes you choose which city to return to, what is the text to be written in the json file?

 Send Instant Message | Send E-Mail | View Profile | Quote Reply | Link
Jump To: « Prev Thread . . . Next Thread » This thread is 97 pages long: 1 2 3 4 5 ... 20 40 60 80 ... 93 94 95 96 97 · «PREV / NEXT»
Post New Poll    Post New Topic    Post New Reply

Page compiled in 0.1168 seconds